Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

was für eine Formel soll ich verwenden?
#1
Hallo zusammen,

ich brauche eine Lösung für mein Problem:

in Excel, es gibt eine Liste mit folgenden Teilenummer

51299080
51299081
51299082
......
etc, in eine andere Liste haben wir folgende Teilenummer

51299080
51299080A
51299080B
51299080C
51299081A
51299081Z
51299082C
.......
ich brauche eine Formel, die mir die letzte Teilenummer / Index in die erste Liste bringt. 
für die erste Position 51299080 von der erste Liste, brauche ich entweder 51299080C oder C
für die zweite Position 51299081 von der erste Liste, brauche ich 51299081Z oder Z etc

Ich habe es mit Hilfsspalten versucht wo ich sagte A =1, B=2 ... aber irgendwie komme ich nicht zu einer Ergebnis.
Vergleich, Index und Sverweis haben mir nichts gebracht :( (kann aber gut sein, dass meine Logik falsch ist)
Habt Ihr eine Idee? Danke schön!
Antwortento top
#2
Hi,

so?
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
151299080C51299080512990800
251299081Z51299080A51299080A
351299082C51299080B51299080B
451299080C51299080C
551299081A51299081A
651299081Z51299081Z
751299082C51299082C

ZelleFormel
B1=VERWEIS(A1;$E$2:$F$7)
E1=LINKS(D1;8)*1
F1=WENN(LÄNGE(D1=9);RECHTS(D1;1);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Estera_Gabriela
Antwortento top
#3
WillWissens Beispiel:

B1[:B3]: =RECHTS(INDEX(D:D;VERGLEICH(A1&"";INDEX(LINKS(D$1:D$7;8);))))

(Spalte D ist sortiert)
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • Estera_Gabriela
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste