Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

sverweis
#1
Hallo zusammen,

ich benötige folgende hilfe:

Ich habe zwei Tabellenblätter mit jeweils Name, Artikelnummer und Preis. Die Preise möchte ich vergleichen und in der Tabelle1 unter Spalte D nur die ausgeben, die nicht übereinstimmen. Nur habe ich das Problem das in Tabelle 2 einige Artikelnummern nur zwei Buchstaben enthalten (in diesem Fall "AS") und im Tabellenblatt1 zusätzlich eine nummer (Bsp. AS1). Daher soll er sobald "AS" drin steht zusätzlich den Namen Vergleichen. Ist das mit sverweis lösbar?

anbei die noch die Datei.

Vielen Dank.

VG

undso


Angehängte Dateien
.xlsx   sverweis.xlsx (Größe: 12,86 KB / Downloads: 2)
Antwortento top
#2
Moin

Wenn die Daten schon so kaputt sind dann dauert es nicht lange und jemand macht sie noch kaputter.

Hilfsspalte in Spalte C
Code:
=WENN(LÄNGE(B2)=3;LINKS(B2;2);B2)
Der SVERWEIS() verweist dann auf Spalte C:
Code:
=WENNFEHLER(SVERWEIS($C2;Tabelle2!$B$2:$C$7;2;0);"")
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste