Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

richtiger Preis zuordnen
#1
Wie kann ich in Microsoft Excel mit einer Formel bei gleicher Artikelnummer aber anderen Farben und Größen den richtigen Preis zuordnen?
Beispiel siehe Excel Tabelle, Preise kommen aus einer anderen Excel Datei


Angehängte Dateien
.xls   Beispiel Excel Tabelle.xls (Größe: 18 KB / Downloads: 12)
.xls   Beispiel Preisliste.xls (Größe: 18 KB / Downloads: 8)
Antworten Top
#2
Hola,
Summewenns()
Summenprodukt()
https://www.herber.de/excelformeln/pages...effer.html
....


Gruß,
steve1da
Antworten Top
#3
Hallo,

mit dem SVerweis.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antworten Top
#4
Zitat:Preise kommen aus einer anderen Excel Datei
Die Datei macht keinen Sinn wenn die andere Datei nicht dabei ist.
Aber so wie es aussieht passt mindestens einer meiner Vorschläge.
Antworten Top
#5
Habe eine Preisliste Beispiel hinzugefügt.
Über einfach kopieren funktioniert nicht, da die Artikel in den Excel Datein nicht in der selben Zeile stehen.
Antworten Top
#6
Code:
=SUMMENPRODUKT(('[Beispiel Preisliste.xls]Tabelle1'!$A$2:$A$7=A2)*('[Beispiel Preisliste.xls]Tabelle1'!$B$2:$B$7=B2)*('[Beispiel Preisliste.xls]Tabelle1'!$C$2:$C$7=C2)*('[Beispiel Preisliste.xls]Tabelle1'!$D$2:$D$7))
Antworten Top
#7
Oder auch Filtern:

=FILTER('[Beispiel Preisliste.xls]Tabelle1'!$D$2:$D$7;('[Beispiel Preisliste.xls]Tabelle1'!$A$2:$A$7=A2)*('[Beispiel Preisliste.xls]Tabelle1'!$B$2:$B$7=B2)*('[Beispiel Preisliste.xls]Tabelle1'!$C$2:$C$7=C2))

oder ein Verweis (hier als XVerweis)

=XVERWEIS(A2&B2&C2;'[Beispiel Preisliste.xls]Tabelle1'!$A$2:$A$7&'[Beispiel Preisliste.xls]Tabelle1'!$B$2:$B$7&'[Beispiel Preisliste.xls]Tabelle1'!$C$2:$C$7;'[Beispiel Preisliste.xls]Tabelle1'!$D$2:$D$7)

oder Summewenns

=SUMMEWENNS('[Beispiel Preisliste.xls]Tabelle1'!$D$2:$D$7;'[Beispiel Preisliste.xls]Tabelle1'!$A$2:$A$7;A2;'[Beispiel Preisliste.xls]Tabelle1'!$B$2:$B$7;B2;'[Beispiel Preisliste.xls]Tabelle1'!$C$2:$C$7;C2)
Gruß,
Helmut

Win10 - Office365 / MacOS - Office365
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste