Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

pivottabelle
#1
hallo Zusammen,
ich versuche mich gerade an eine Zusammenfassung aller Datumeinträge der MA. aus den intelligenten Tabellen der 12 Monate zu erstellen.
Habe testweise Einträge für Jan.+ Feb. gemacht.Irgenwie sieht das absolut misslungen aus,was mir die Pivottabelle mir darstellt :(

Wer kann mir dabei behiflich sein?

Danke
Antwortento top
#2
Hallöchen,

wenn ich U_Start und U_Ende in die Zeilen nehme sieht es schöner aus. Mal abgesehen davon, dass ich den Aufbau der Datei weniger schön finde ...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
Hallo
um da ein paar Listen aneinanderzufügen wäre PQ besser geeignet. Oder ein kurzes VBA Script.

Das Problem ergäbe sich vermutlich nicht, wenn nur eine Jahrestabelle (gleichartige Daten = 1 Tabellenblatt) existieren würde.

Abgesehen davon wäre es aus meiner Sicht besser, alles in einem Thema zu behandeln, da es sich offensichtlich immer um dieselbe Tabelle handelt.
Für jedes Problem nur ein löchriges Stückwerk dieser Tabelle  in einem neuen Thema hochzuladen ist nicht sinnvoll.
Cadmus
Antwortento top
#4
Hier ein kurzes VBA-Skript, einzufügen inn ein allgemeines Modul:

Code:
Sub Kopieren()
   Dim Blatt As Worksheet
   Dim FormTab As ListObject
   Dim Zeile As Range
   Dim dict As Object
   Set dict = CreateObject("Scripting.Dictionary")
  
   For Each Blatt In ThisWorkbook.Worksheets
      For Each FormTab In Blatt.ListObjects
         If FormTab.Name Like "u_*" Then
            For Each Zeile In FormTab.DataBodyRange.Rows
               If Zeile.Columns(1) <> "" Then
                  dict.Add dict.Count, WorksheetFunction.Index(Zeile, 1, 0)
               End If
            Next Zeile
         End If
      Next FormTab
   Next Blatt
   With Worksheets("Zusammenfassung").ListObjects("U_zusammenfassung").DataBodyRange
      .Offset(.Rows.Count).Resize(dict.Count, dict(1).Columns.Count) = WorksheetFunction.Index(dict.items, 0, 0)
   End With
End Sub


Die Zeilen werden an die Zusammenfassung unten angehängt.
Ist vielleicht umständlich gemacht. Habe mir da was zusammengeschnipselt.
Würde gerne Eure geschätzte Meinung dazu lesen.



Gruss, Raoul
Antwortento top
#5
moin Raoul21
Danke für deine Mühe ein VBA. zu bastel.
PQ, hat meine MacVersion nicht.Und VBA kann ich nicht auf meine IPad anwenden.
Daher denke ich,das Tabellenzusammenführung außer Pivot eine Möglichkeit ist,eine Zusammenfassung zu erstellen.

Danke
Antwortento top
#6
Hi Schluckspecht,
na, dann hast Du ja alles. Was willst Du mehr? (Dein Link zeigt neben einer Formellösung auch ein Makro.)

Händisch würde ich Deine Aufgabe so lösen: In jedem Monatsblatt die nichtleeren Zeilen wegfiltern, den Datenbereich mit Strg+A auswählen und Strg+C kopieren, Filter wieder öffnen, dann in der Zusammenfasung an der gewünschten Stelle einfügen.

Alles Gute noch mit Deinem IPad. Gruss, Raoul
Antwortento top
#7
hallo zusammen,
ein Wunsch hätte ich noch.
Momentan sind die Urlaubsberechnungen im Blatt "Zfassung" auf eine 5Tg.Woche ausgelegt.
Da einige Mitarbeiter eine 6 Tg.Woche haben,möchte ich gerne die Formel erweitern für die
bestimmten MA.
Ich stelle mir das so suche in Spalte A (Zfassung) die Namen Ma 15,19 + 7 und berechne in Spalte f
die 6Tg.Woche.Ansonsten für die restlichen MA die 5Tg.Woche.
So erspare ich mir für jedes Monatsblatt ab Spalte Ag8 die Formel einzugeben.Was z.Z. gegeben ist.

Danke
Antwortento top
#8
Hi Schluckspecht,

Füge im Blatt "Mitarbeiter" eine neue Spalte in B ein. Jeder MA mit 5-Tagewoche bekommt eine 5 in Spalte B.

Schreibe im Blatt "Zfassung" Zelle F16 folgende Formel:

Code:
=WENN(B16="";"";NETTOARBEITSTAGE.INTL(B16;C16;WENN(SVERWEIS([@Name];Mitarbeiter!$A$1:$B$31;2;FALSCH)=5;1;11);Feiertage))

Damit wird bei allen 5-Täglern Samstag und Sonntag, bei allen anderen Sonntag als Wochenende gezählt.

Gruss,
Raoul
Antwortento top
#9
@Raoul21
ey,Super.DankeSmile

zu früh gefreut.
bei leerzeilen in Zfassung bekomme ich trotz Formel:
=WENN(B20="";"";NETTOARBEITSTAGE.INTL(B20;C20;WENN(SVERWEIS([@Name];Mitarbeiter!$A$1:$I$31;9;FALSCH)=5;1;11);Feiertage))
#Wert! anzeige. Die sollten weg.

Danke
Antwortento top
#10
ok,wie dem auch sei,er gibt die Werte falsch wieder.
Kann nicht sein,das bei 2 Ma im gleichen Zeitraum unterschiedliche Anzahl von U Tagen hat.
s.Ma 5+ Ma 12 im Blatt "Zfassung" Während die Berechnung im Blatt "Jan." korrekt ist.

Mit der Werteanzeige,gut das kann man zur Not mit der 0 Filterung ausblenden.

Danke
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste