Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

neuen Zeilen bei Abfragen aus Arbeitsmappe werden nicht geladen
#1
Hallo zusammen,

ich habe eine Datei, in der ich mehrere Abfragen aus anderen Arbeitsmappen eingefügt habe. In den Quelldateien werden Daten gesammelt, die ich in einer Datei sammele und dort weiter Verarbeite.

Beispiel:
Ich habe eine Datei ABC und eine Datei DEF. Beide Dateien sind gleich aufgebaut und ich hole mit aus beiden Dateien jeweils die Spalte C (Column3) vom Tabellenblatt 1. Es wird lediglich die eine Spalte abfefragt.

Auf dem Tabellenblatt 1 in der Datei ABC waren zum Zeitpunkt als ich die Abfrage erstellt habe lediglich Daten bis Zeile 36 eingetragen. Mittlerweile stehen dort Daten bis Zeile 250, aber diese werden mir beim aktualisieren der Abfrage nicht in der Zieldatei angezeigt. Die Abfrage bearbeitet immer nur die ersten Zeilen bis 36, so wie ich die Abfrage damals erstellt habe. Dabei habe ich aber nur einen Bereich definiert, sondern nur die Spalte.

Kann mir jemand sagen wo / ob man das irgendwo einstellen kann?
Oder habe ich beim Erstellen der Abfrage etwas falsch gemacht?

MfG
Olaf
Antwortento top
#2
Hola,

und wie genau fragst du die Daten ab?

Gruß,
steve1da
Antwortento top
#3
Hallo Olaf,

vermutlich holst du dir die Daten per Makro, aus der Datei DEF, dann einfach deinen CODE, von To 36 bis zur letzten Zeile änderen.
Etwas mehr Infos, sollte man schon haben  von dir, um gezielt helfen zu können.
Mit freundlichen Grüßen
Karl
Antwortento top
#4
oh .. sorry!
Wat vielleicht etwas dusselig beschrieben.

Ich hole die Daten über eine Abfrage (Power Query?)
Registerkarte Daten -> Neue Abfrage -> Aus Datei -> Aus Arbeitsmappe

Etwas weiter rechts ist dann der Button "Alle aktualisieren" bzw. die Aktualisierung nehme ich über ein Makro vor: ("ActiveWorkbook.RefreshAll").
Macht aber keinen Unterschied ob ich den Button oder das Makro benutze.

MfG
Olaf
Antwortento top
#5
Hallo Olaf,

hast Diu eventuell die Option "Bereich von Zeilen beibehalten" in der Abfrage gewählt?
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#6
(15.06.2019, 08:33)schauan schrieb: Hallo Olaf,

hast Diu eventuell die Option "Bereich von Zeilen beibehalten" in der Abfrage gewählt?

Ja ... ich denke das wird es sein!
Genau so eine Option suche ich die ganze Zeit, kann sie aber nicht finde. Wo versteckt sich dieser Haken?
Antwortento top
#7
Hallöchen,

findest Du beim Bearbeiten der Abfrage:

   
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • Liscom
Antwortento top
#8
Hab's gefunden. Vielen Dank!

Es war dort zwar kein Wert eingetragen, hab es jetzt aber mal von 1 bis 9999 eingetragen und nun funktioniert es.
Mehr als 9999 Einträge werden auf jeden Fall nicht vorkommen;)

MfG
Olaf
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste