Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

dublikate mit allen werten zusammeführen
#1
Hallo,

hab eine Liste mit Daten. siehe Bild 01

Mit der funktion dublikate entfernen, werden leider auch die daten von den entfernten dublikaten gelöscht. siehe Bild 02

Ist es möglich, die Daten von den Dublikaten beizubehalten und in eine Zeile zu transferieren? siehe Bild 03

LG
Husan


Angehängte Dateien Thumbnail(s)
           
Antwortento top
#2
Moin,

lad mal bitte deine Beispieldatei hoch anstelle der Bildchen und beschreibe etwas genauer, was du haben willst. So ganz habe ich dich nicht verstanden.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
die Beispieldatei ist wie bei Bild 01 angegeben.
Mit der Funktion Duplikate entfernen angewendet auf Spalte A gehen leider auch die Wert verloren von den gelöschten Duplikaten. --> Bild 02
Ich will aber das die Werte nicht gelöscht werden, sondern dem Name zugeordnent werden.---> Bild 03 (so hätte ich es gerne)

LG
Antwortento top
#4
Hi,

was ist an dem Wort Beispieldatei nicht zu verstehen? Ich meine dait keine Bildchen, sondern eine .xlsx!
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
Hallo Husan

Du glaubst doch nicht im ernst das hier jemand das nachbaut? Wenn ja dann bist du auf dem Holzweg.
Gruß
Ivan 16
Antwortento top
#6
Sorry


Angehängte Dateien
.xlsx   test.xlsx (Größe: 10,08 KB / Downloads: 5)
Antwortento top
#7
Hallöchen,

ich hoffe mal, ich bin nicht auf dem Holzweg, denn ich glaube im ernst dass zuweilen auch ohne Beispielmappe eine Erklärung hilft, wie man vorgehen könnte -  100  - daher ohne was nachzubauen ein Tipp:

- Markiere in einer Hilfsspalte die Duplikate z.B. mit einem x oder einer Zahl.
-->   Duplikate mit ZÄHLENWENN oder ZÄHLENWENNS zählen bekommst Du ohne Beispielmappe hin?
- Anschließend filterst Du die Duplikate anhand der Hilfsspalte, kopierst sie und fügst sie in ein anderes Blatt ein.
- Dann löschst Du die Duplikate und die Hilfsspalte.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • Husan
Antwortento top
#8
Hi,

so würde ich es lösen.

1. Spalte A an andere Stelle kopieren und duplikate entfernen
2. Siehe Tabellenausschnitt mit einem SVERWEIS() die Daten holen (mit einem WENNFEHLER() um die Formel herum kannst du die #NV ausschließen)
3. Alles kopieren und als Werte wieder einfügen.
4. Die nicht mehr benötigten Spalten löschen

Arbeitsblatt mit dem Namen 'Tabelle4'
GHIJK
3Deschapelles, Alexandre   2625264026402640
4Mouret, Jacques   2484247924792474
5Boncourt, Hyacinthe   2363237223722382
6Alexandre, Aaron   2356235823582360
7Weyle   2325233223322339
8Cochrane, John   2317233223322327
9Petrov, Alexander   2251225922592273
10Hubbard   2131#NV#NV#NV
11Tolfrey   2131#NV#NV#NV
12Brand, John   2104#NV#NV#NV
13Lomax   2013#NV#NV#NV
14Mercier, Francis   2013#NV#NV#NV
15de la Bourdonnais, Louis   0263526352642
16Lewis, William   0255225522560
17Tundutov   021022102#NV

ZelleFormel
H3=SVERWEIS($G3;$A$2:$E$43;2;0)
I3=SVERWEIS($G3;$A$15:$E$43;3;0)
J3=SVERWEIS($G3;$A$25:$E$43;4;0)
K3=SVERWEIS($G3;$A$35:$E$43;5;0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Husan
Antwortento top
#9
Thumbs Up 
Viele Dank, 
für eure Hilfe.
Schauan Thumps_up
WillWissen Thumps_up
Antwortento top
#10
Hallo, wenn das das gewünschte Ergebnis ist..:

Arbeitsblatt mit dem Namen 'Tabelle4'
IJKLM
2Name1820182118221823
3Alexandre, Aaron   2356235823582360
4Boncourt, Hyacinthe   2363237223722382
5Brand, John   2104
6Cochrane, John   2317233223322327
7Deschapelles, Alexandre   2625264026402640
8Hubbard   2131
9Lewis, William   255225522560
10Lomax   2013
11Mercier, Francis   2013
12Mouret, Jacques   2484247924792474
13Petrov, Alexander   2251225922592273
14Tolfrey   2131
15Tundutov   21022102
16Weyle   2325233223322339
17de la Bourdonnais, Louis   263526352642
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

dann kann man das mit Power Query ganz leicht erreichen... Tabelle nach Power Query laden --> erste Spalte markieren --> andere Spalten entpivotieren ---> Danach wieder Pivotieren nach Wert. Fertig. Nach Excel laden - sich freuen... 

Kommt ohne Formeln aus. Ist dynamisch... Arbeitsaufwand minimal. Wenige Klicks... Zeitaufwand insgesamt weniger als 20 sec. Erste Spalte wird automatisch sortiert....
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste