Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

bestimmte Inhalte suchen und ganze Zeile ausgeben
#1
Hallo  43
ich bin mir sicher, dass hier bereits nach gefragt wurde, kann aber nichts für mich brauchbares finden. Vielleicht kann mir hier einer helfen. Huh

Ich habe eine wöchentliche Excel mit großen Datensätzen. Ca. 6000-7000 Zeilen mit je ca. 25 Spalten.
Ich möchte in dem Tabellenblatt immer wieder nach den gleichen (ca. 60) Inhalten in der Spalte C suchen und dann in einem anderen Tabellenblatt bzw. in einer anderen Datei die gesamten Zeilen auflisten.
Die Quell-Tabelle (Pivot) ist nicht geordnet. Der Zelleninhalt kommt immer nur einmal vor.

In meiner angehängten Beispieldatei suche ich nach 
Birnen_Nord_3
Heidelbeeren_Süd_2
Himbeeren_Ost_2

und möchte in dem anderen Tabellenblatt

Birnen_Nord_3...ganze Zeile...
Heidelbeeren_Süd_2 ...ganze Zeile...
Himbeeren_Ost_2 ...ganze Zeile...

gelistet ausgeben, um die Daten weiterzuverarbeiten.
Die ausgegebene Liste muss also immer gleich angeordnet sein. 
Wie erwähnt, ist der gesuchte Inhalt immer der gleiche und folglich ist Liste immer identisch gleich groß.

Kann ich das mit einer Formel lösen oder nur sinnvoll mit VBA?

Danke vorab  19

Gruß, Andi


Angehängte Dateien
.xlsx   Früchte.xlsx (Größe: 12,42 KB / Downloads: 9)
Antworten Top
#2
formel in Spalte D nach unten ziehen

Arbeitsblatt mit dem Namen 'Tabelle2'
CDEFGHIJKLMNO
13Birnen_Nord_3896932341446562352523
14Heidelbeeren_Süd_2236931554647548985612
15Himbeeren_Ost_2897425711295238912452
16

ZelleFormel
D13=XVERWEIS($C13;Tabelle1!$C$4:$C$14;Tabelle1!$D$4:$O$14;"";0;1)
Antworten Top
#3
Smile 
Vielen Dank Ralf - Klappt hervorragend mit XVERWEIS  Shy
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste