Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

bedingte Formatierung mit 2 Bedingungen in einer Zeile
#1
Hallo Leute,

nach dem Studium von etlichen Videos und dem Lesen von einigen Beiträgen stehe ich noch immer vor einem Problem.
Ich würde gern in einem Tabellenblatt Zellen formatieren (einfärben) wenn in einer Zeile einer Tabelle auf einem anderen Tabellenblatt zwei Werte aus verschiedenen Spalten zutreffen.
Dabei war mein erster Gedanke, eine WENN Funktion mit mehreren Bedingungen. Das geht nur leider nicht, da die einzelnen Bedingungen in der Tabelle öfter vorkommen, ich aber nur dann die Formatierung möchte wenn die beiden Bedingungen auch in der gleichen Zeile sind. Zur Verdeutlichung:

Personalnummer     Schrank        Datum       Fach

123                             A               01.01.19     2
456                             B               01.01.19     3
789                             A               02.01.19     1
321                             A               03.01.19     3
654                             B               01.01.19     2
.
.
.

Ich habe im zweiten Tabellenblatt eine Übersicht aller Schränke mit ihren Fächern und möchte die Zellen der Fächer so formatieren, dass man auf einem Blick sieht, welche frei und welche belegt sind.
Ich hoffe, das war jetzt halbwegs verständlich?
Würde mich freuen, einen kleinen Denkanstoß zu bekommen.

Viele Grüße und ein schönes Wochenende für alle hier. Blush
Antwortento top
#2
Hola,

und warum zeigst du uns nicht wie die 2. Tabelle aufgebaut ist?
Woher sollen wir wissen wann ein Fach frei ist und wann nicht?

Gruß,
steve1da
Antwortento top
#3
Sorry, dachte ich habe mich klar ausgedrückt. Im zweiten Tabellenblatt gibt es quasi nur eine Darstellung eines jeden Schranks.

   Schrank A                       Schrank B

  1  2   3   4                      1  2   3   4
  5  6   7   8                      5  6   7   8
  9 10 11 12                     9 10 11 12

Dabei ist jede Fachnummer eine eigene Zelle, die farblich hervorgehoben werden soll je nachdem, ob das Fach vergeben ist oder nicht.

Ein Fach ist vergeben, wenn es in Tabelle 1 aufgeführt ist.

Ich hoffe, es ist jetzt klarer geworden?

Viele Grüße
Antwortento top
#4
Hola,

jetzt wissen wir immer noch nicht wann ein Fach vergeben ist.
Lade bitte eine Beispieldatei hoch (kein Bild).

Gruß,
steve1da
Antwortento top
#5
Wenn meine Worte so schwer zu verstehen sind, lade ich gern eine Beispieldatei hoch.

Dabei sind im Tabellenblatt "Ausgabeliste" alle Fächer enthalten die bereits vergeben wurden. Da jeder Schrank aber 12 Fächer hat, sind auch noch diverse Fächer frei. Im Tabellenblatt "Schrankübersicht" Sind alle Schränke mit allen Fächern enthalten. In dieser Übersicht möchte ich sehen, welche Fächer bereits vergeben wurden (Ausgabeliste) und welche noch frei sind.

Ich hoffe, ich konnte Dir und allen anderen jetzt unmissverständlich erklären was ich suche.

Grüße


Angehängte Dateien
.xlsx   test_schrank.xlsx (Größe: 10,43 KB / Downloads: 3)
Antwortento top
#6
Hola,

für Schrank A:
A3 bis D3 markieren. Als Formel in der bed. Formatierung:


Code:
=ZÄHLENWENNS(Ausgabeliste!$B$2:$B$7;$C$2;Ausgabeliste!$D$2:$D$7;B3)

Für Schrank B das gleiche Vorgehen, außer dass du halt $C$2 durch $H$2 ersetzen musst.

Gruß,
steve1da
Antwortento top
#7
Erstmal Danke für Deine Mühen, aber das funktioniert so nicht.

Bei der Formel werden nicht die richtigen Fächer formatiert.

In der angehängten Datei habe ich jetzt im Tabellenblatt "Schrankübersicht" die farblichen Wünsche händisch umgesetzt, um zu zeigen was ich benötige. Vergebene Fächer rot, freie Fächer grün. Mir ist klar, dass ich alle Fächer grün formatieren kann, nur brauche ich ne Formel, die bei den vergebenen Fächern aus grün rot macht.

 Leider ist das "händische" für die Produktivdatei nicht möglich, da sie aus hunderten Datensätzen besteht und ich gern diese "Automatisierung" hätte. Es geht einfach darum, auf einem Blick zu sehen, welche Fächer sind noch frei und können an neue Kollegen vergeben werden. Huh


Angehängte Dateien
.xlsx   test_schrank.xlsx (Größe: 11,81 KB / Downloads: 3)
Antwortento top
#8
Hola,

schön dass du meinen Vorschlag in deiner Datei nicht zeigst....dann könnte man direkt sehen was falsch war.


Code:
=ZÄHLENWENNS(Ausgabeliste!$B$2:$B$7;$C$2;Ausgabeliste!$D$2:$D$7;A3)

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • knuffo
Antwortento top
#9
Vielen Dank, so scheint es zu klappen.

Könntest Du mir noch verraten, welche Parameter ich für Schrank B anpassen müsste? In der Mitte $C$2 durch $H$2 ersetzen schätze ich mal? Sonst noch etwas? Huh 


Beim ersten Versuch wurden jeweils pro Schrank trotz Anpassung nur die Fächer 2 und 10 markiert.

Gruß knuffo
Gruß knuffo 50
Antwortento top
#10
Hola,

nur C2 durch H2 ersetzen.

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste