Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

an freien Tagen Urlaub nicht mit zählen
#1
hallo zusammen,
wie müsste die Formel lauten,damit an freien Arbeitstagen der Urlaub nicht mit gezählt wird?
Besser wäre es natürlich,das man mit der bestehenden Formel in c9 eine erweiterte Formel bastelt,die dafür sorgt,
das keine U-einträge gemacht werden,wenn in Zeile c12 freie Tage vorgegeben sind.

Danke
Antwortento top
#2
Hallöchen,

Du könntest mit der Datengültigkeit einen Abgleich zwischen Urlaubsdaten und Datum in der Liste machen und damit eine Eingabe verhindern.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
ok,danke
so wie ich es dann verstanden habe,handelt es sich um eine benutzer def. Datengültigkeit.
Gut,wie sieht dies im praktischen Teil aus?

Danke
Antwortento top
#4
Eigentlich ist =NETTOARBEITSTAGE() oder =NETTOARBEITSTAGE.INTL() Dein Freund.
Antwortento top
#5
Hallöchen,

so bekommst Du z.B.. kein U und auch nix anderes am 2. und 3. September rein. Wenn Du da krank bist und ein k rein soll, dann entweder unten das Datum aus der "Urlaubsliste" löschen oder die Prüfung zusätzlich auf "u" ausdehnen. Zusätzlich könntest Du auch auf Wochenenden und Feiertage prüfen, falls die auch rausfallen sollen Smile

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
101. Sep02. Sep03. Sep04. Sep05. Sep
2uu
3
4
5Urlaub
602. Sep
703. Sep

ZelleGültigkeitstypOperatorWert1Wert2
A2Benutzerdefiniert=ZÄHLENWENN($A$6:$A$7;A1)=0
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#6
moin,
@schauan
danke für die Hilfestellung.Bin aber wohl zu doof es auf meine Datei umzusetzen.
Antwortento top
#7
Hallöchen,

wenn Du mit den freien Tagen die Feiertage meinst, dann z.B. so:

Arbeitsblatt mit dem Namen 'Kalender'
ABCDE
7Personalnr.NameFrSaSo
8010203
91Muster...1
102Muster...2

ZelleGültigkeitstypOperatorWert1Wert2
C9Benutzerdefiniert=ZÄHLENWENN(Dateneingabe!$K$2:$K$10;C$8)=0
D9Benutzerdefiniert=ZÄHLENWENN(Dateneingabe!$K$2:$K$10;D$8)=0
E9Benutzerdefiniert=ZÄHLENWENN(Dateneingabe!$K$2:$K$10;E$8)=0
C10Benutzerdefiniert=ZÄHLENWENN(Dateneingabe!$K$2:$K$10;C$8)=0
D10Benutzerdefiniert=ZÄHLENWENN(Dateneingabe!$K$2:$K$10;D$8)=0
E10Benutzerdefiniert=ZÄHLENWENN(Dateneingabe!$K$2:$K$10;E$8)=0
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg

und, wie gesagt, auch auf die Wochenenden erweiterbar

Arbeitsblatt mit dem Namen 'Kalender'
C
9

ZelleGültigkeitstypOperatorWert1Wert2
C9Benutzerdefiniert=UND(WOCHENTAG(C$8;11)<6;ZÄHLENWENN(Dateneingabe!$K$2:$K$10;C$8)=0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#8
moinSmile
nein,ich rede von den Schichtfreien Tagen.An diesen Tagen sollen die U-Einträge
nicht mitgezählt werden.

Danke
Antwortento top
#9
Hallöchen,

wo finde ich die freien Tage?
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#10
@schauan
die freien tage sind in zeile 12 mit - gekennzeichnet.
was ich jetzt versucht habe,ist mit dieser formel :=WENN(UND(ZÄHLENWENNS(Datumeingabe!$I$5:$I$24;"<="&C$8;Datumeingabe!$J$5:$J$24;">="&C$8);C$12<>"-");"u";"") die U's auszublenden,wenn in Zeile 12 ein - vorhanden ist.Das klappt auch.Nur dann fehlt mir die Krankanzeige dann in Zeile 9 ( spalte: ab26)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste