Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

ab dem * neue Zeile und wert reinschreiben
#1
Hallo Leute,

ich habe mal ein ProblemSmile

Ich habe Daten in folgender Form in einer Zelle:

*GPS#052#80#958006420813#RB58519NN#20200224T133322#11.04791833#49.44939833#0.55#0###SB##958006420813;0*GPS#052#79#958006420813#RB58519NN#20200224T133322#11.04791833#49.44939833#0.55#0###TF##958006420813;0*GPS#052#78#958006420813#RB58519NN#20200224T133322#11.04791833#49.44939833#0.55#0###SF##958006420813;0*GPS#052#77#958006420813#RB58519NN#20200224T133322#11.04791833#49.44939833#0.55#0###TV##958006420813;0

Könnt Ihr mir sagen wie ich es hin bekomme, das ab dem * die Werte in in eine neue Zeile rein geschrieben werden?

Habe davon sehr viele werte etwa 2000 Stück und möchte diese ungern händisch trennenSmile
Antwortento top
#2
Hi,

probier's mal mit Text in Spalten (Menü Daten/Datentools)
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hi,

ja das habe ich ja schon versucht, dann schreibt er mit es ja in nächste Spalte,

jedoch muss es in die nächste ZeileSmile
Antwortento top
#4
Wenn Du das gemacht hast gehst du auf Kopieren - Inhalte einfügen - Transponieren ...

Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#5
Hallo,

für Dein kleines Beispiel eine kleine VBA Lösung:

Code:
Sub splitten()
  Dim i As Long
  Dim a
  a = Split(Cells(1, 1), "*")
  For i = LBound(a) To UBound(a)
      Cells(i + 1, 2) = a(i)
  Next i
End Sub
Gruß Atilla
Antwortento top
#6
Hallo,

hier (der Vollständigkeit halber...) eine Lösung mit Formeln + Hilfsspalte.

Wenn der aufzusplittende Text in B3 steht:

Formel in B6:
=WENNFEHLER(SUCHEN("~*";$B$3;B5+1);"")
Ermittelt die Positon des *
(B5 muss leer sein!)

Formel in C6:
=WENNFEHLER(TEIL($B$3;B6+1;WENN(UND(B6>0;B7="");LÄNGE($B$3)-B6;B7-B6-1));"")
Splittet den Text auf.

Ich bin davon ausgegangen, dass der Text immer mit einem * beginnt.
Sollte vor dem ersten * noch was stehen, müsste die Formel in C6 angepasst werden.

Gruss
Fred


Angehängte Dateien
.xlsx   Text_aufsplitten_fs.xlsx (Größe: 10,95 KB / Downloads: 3)
Antwortento top
#7
Moin!
Ich würde das Array gleich direkt in den Bereich schreiben:
Code:
Sub Zeilentrenner()
Dim arr
arr = Split(Mid$("*GPS#052#80#958006420813#RB58519NN#20200224T133322#11.04791833#49.44939833#0.55#0###SB##958006420813;0*GPS#052#79#958006420813#RB58519NN#20200224T133322#11.04791833#49.44939833#0.55#0###TF##958006420813;0*GPS#052#78#958006420813#RB58519NN#20200224T133322#11.04791833#49.44939833#0.55#0###SF##958006420813;0*GPS#052#77#958006420813#RB58519NN#20200224T133322#11.04791833#49.44939833#0.55#0###TV##958006420813;0", 2, 9 ^ 9), "*")
  Range("A1").Resize(UBound(arr) + 1) = _
    WorksheetFunction.Transpose(arr)
End Sub

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste