Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zufallsgenerator Excel
#1
Hallo zusamen,


ich muss für ein Projekt bestimmte Bezeichnungen in verschiedenen Zellen zufällig verteilen. Um es verständlicher zu machen hänge ich eine Datei an. In Spalte "A" habe ich einfach eine Numerierung von 1-500. In Spalte "B" befindet sich ein Code der nur zur unterscheidung dient. Was ich bräuchte ist ein Code, mit dem ich in Spalte "E" den Begriff "B1" 100 mal zufällig auf die 500 Zellen der Spalte verteilen kann. Das gleiche dann auch in Spalte F nur hier ist der Code "D3" und er müsste 300mal zufällig auf die Zeilen der Spalte verteilt werden.
Vielleicht kann mir hier ja einer von euch weiterhelfen.
Schon mal Danke im Voraus!!

Gruß Fabi


Angehängte Dateien
.xls   Auftragsabwicklung - Kopie.xls (Größe: 55 KB / Downloads: 7)
Antwortento top
#2
Hallo Fabi,

lies mal bitte deinen Beitrag aus Sicht eines Unbeteiligten - ich verstehe nicht, was du genau haben willst.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hi,

also im Grunde möchte ich eigentlich nur dass in Spalte E das Wort B1 zufällig 100mal verteilt wird. Und das im Zellenbereich E2 bis E501.
Ist das ein bisschen verständlicher? :D
Antwortento top
#4
Moin!
A2:A501: =ZUFALLSZAHL()
B2:B501: =WENN(A2 < KKLEINSTE(A:A;101);"B1";"")

AB
1ZufallMeine_B1
20,0190016B1
30,26635656
40,57559046
50,07796976B1
60,32332628
70,13430712B1
80,98033045
90,86256708
100,06810132B1
110,95007854
120,3157055
130,39906691
140,42515541
150,06548385B1
160,81479382
170,68258365

ZelleFormel
A2=ZUFALLSZAHL()
B2=WENN(A2<KKLEINSTE(A:A;101);"B1";"")

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#5
Ein bisschen eklig ohne Hilfszellen:

E2[:E501]: =ZUFALLSZAHL() benDefFmt ;;
E2[:E501]: =--(E2<KKLEINSTE(E$2:E$501;101)) als bedF mit der benDefFmt Zahlenformatierung "B1";;

Lässt sich von außen nicht auswerten! Nur optisch. (Bei RPP63 geht es aber)
Antwortento top
#6
Einen habbich noch!
In einem aktuellen Excel (was der TO hat) reichen auch lediglich zwei Formelzellen:
AB
1ZufallMeine_B1
20,469159663
30,523144677
40,206098525B1
50,140863645B1
60,267828484
70,204257334B1
80,598320751
90,506437183
100,879084438

ZelleFormel
A2=ZUFALLSMATRIX(500)
B2=WENN(A2#<KKLEINSTE(A2#;101);"B1";"")

EDIT:
Oder auch ohne Hilfsspalte:
E
1Meine_B1
2B1
3
4
5
6
7B1
8
9

ZelleFormel
E2=WENN(ZUFALLSMATRIX(500)<KKLEINSTE(ZUFALLSMATRIX(500);101);"B1";"")
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
[-] Folgende(r) 1 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • Der Steuerfuzzi
Antwortento top
#7
Hm ... wenn ich 2x ZUFALLSZAHL() in einer Formel verwende, sind es nicht die gleichen. Beweis:

=ZUFALLSZAHL()&ZUFALLSZAHL()

Bei 2x ZUFALLSMATRIX() müssten beide Matrizen in Deiner Formel aber gleich sein, sonst geht das schief!

Kannst Du mal prüfen, ob Dein Ergebnis valide ist? Insbesondere müsstest Du jedes Mal genau 100 Mal "B1" erhalten. Bei ungleichen Matrizen ergeben sich um 100 pendelnde Anzahlen "B1".
Antwortento top
#8
Du hast Recht!
Da ich nicht bis 100 zählen kann 21 habe ich dies mit
=WENN(ZUFALLSMATRIX(20) < KKLEINSTE(ZUFALLSMATRIX(20);6);"B1";"")
überprüft.
Haut nicht hin!

Daher tatsächlich nur mit Hilfs-Spalte, besser -Matrix:
FG
10,49147649
20,30218029
30,52721262
40,06844268meine5
50,77504185
60,25436862meine5
70,88030902
80,48011781
90,22659889meine5
100,880249
110,05422711meine5
120,42274027
130,91483487
140,78616364
150,82045178
160,67352018
170,84006383
180,26029721meine5
190,50885623
200,465651

ZelleFormel
F1=ZUFALLSMATRIX(20)
G1=WENN(F1#<KKLEINSTE(F1#;6);"meine5";"")
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
[-] Folgende(r) 1 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • Der Steuerfuzzi
Antwortento top
#9
Hallo,

Danke für die schnelle Hilfe. das klappt gut!!! Beutze die Variante mit der Matrix. Ansonsten hätte ich das bei 15 Listen händisch machen müssen. Blush

Vielen lieben Dank euch!
Antwortento top
#10
In E2:E501
PHP-Code:
=IF($I2<100;"B1";""

In D2:D501
PHP-Code:
=IF($I2<300;"D3";""

In H2:H501
PHP-Code:
=RAND() 

In I2:I501
PHP-Code:
=RANK($H$2:$H$501;$H$2:$H$501
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste