Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zellen kennzeichnen, die korrekte Berechnung enthalten
#1
Hallo!

Ich habe zurzeit folgendes Problem:
In einem Formelrechner den ich mir zusammengestellt habe, gibt es mehrere korrekte Wege auf eine Lösung zu kommen.
Nehmen wir als Beispiel den "Safety factor z" aus dem Anhang.
In der Spalte "Value" trage ich den Wert selber ein, wenn er z.b in der Aufgabenstellung gegeben ist.
In den Spalten "Result" (hier von C bis H), berechnet Excel auf verschiedenen Wegen ein mögliches Resultat für diesen Wert.
Allerdings stimmen nicht immer alle Werte. Der Grund dafür ist, dass manche Rechenwege Daten erfordern, die noch nicht gegeben sind.
Dann erscheint in der Zelle entweder so etwas wie #NUM oder #DIV/0. Das ist auch kein Problem so.
Allerdings berechnet Excel manchmal auch fälschlicherweise ein falsches Ergebnis, da, wie gesagt, nicht alle Daten gegeben sind, dies für Excel aber kein
Problem darstellt da nicht durch 0 geteilt wird oder ähnlich.
Dies sehen wir gut in der Zelle C22. Für die Berechnung fehlt eigentlich der Wert von B24, stört aber Excel nicht.
Dies erschwert es mir natürlich, das richtige Ergebnis zu finden.
Bis jetzt habe ich die Zellen immer angeklickt und geschaut, ob auch tatsächlich alle nötigen Werte für die Berechnung vorhanden waren, jetzt möchte ich das
aber mehr oder weniger automatisieren.

Gibt es eine Möglichkeit, dass Excel mir automatisch alle Zellen markiert, die nur Ergebnisse enthalten, die aus korrekten Berechnungen stammen?
Hier definiert sich korrekt als: Alle Daten die zur Berechnung nötig waren, waren vorhanden. Eine leere Zelle zählt nicht als 0, ergo ist eine Berechnung die eine leere Zelle enthält, falsch.

Nice to have, aber momentan nicht so wichtig: Gibt es eine Möglichkeit, diesen einen richtigen Wert, dann auch automatisch in die "Value" Spalte zu kopieren?

Vielen Dank schonmal für die Hilfe!

Tom


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hallo
ich würde die Formeln so erweitern, das sie grundsätzlich erst dann etwas anzeigen wenn alle relevanten Werte vorhanden sind, das würde auch alle Fehlermeldungen unterdrücken.

Beispiel: A1 bis A3 dürfen nicht leer sein
=WENN((A1<>"")*(A2<>"")*(A3<>"");FORMEL;"")
Die Formel wird erst berechnet, wenn in allen Feldern was drin steht. (Null ist erlaubt)

Ist es ein größererer Bereich, lassen sich die nicht leeren Zellen auch zählen:
=WENN(ZÄHLENWENN(A1:A3;"<>"&"")=3;FORMEL;"")
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste