Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zellen füllen bis Wert erreicht ist
#1
Hallo Liebe Forum. 

Ich verzweifel gerade an einer Excel Tabelle. Einen Screenshot packe ich hier direkt mal in die Attachments

Das Ziel ist es Das in den Zellen A17:J17 ein Wert wieder gegeben werden soll aus der Tabelle rechts (Spalte M) Und Zwar so lange bis Der Wert aus Spalte U Erreicht ist Anzahl an Zellen in der unteren Tabelle. Die Zahlen von 10 bis 69 können an der Stelle ignoriert werden da sie nur der Orientierung gelten. 

Ich habe schon probiert mit einer Wenn Formel zu arbeiten. Leider ohne Erfolg. 

Vielleicht kann da jemand ein wenig unterstützen oder hat eine Idee wie wir uns dem ganzen nähern können


Angehängte Dateien Thumbnail(s)
   
Antworten Top
#2
Hallo,
mit Bildchen kann man nicht arbeiten.
Die Tabelle wäre eine Alternative.

MfG Günter
Wenn Thema gelöst, dann bitte kennzeichnen.
Antworten Top
#3
Hola,

Zitat:bis Der Wert aus Spalte U Erreicht ist Anzahl an Zellen in der unteren Tabelle.
Bitte was?
Im Bildchen ist zu sehen das da wohl Texte in Zeile 17 stehen - was das mit der 1 in Spalte U zu tun haben soll, keine Ahnung.
Ist das auf dem Bildchen schon das Wunschergebnis? Wenn ja, warum?
Gruß
steve1da
Antworten Top
#4
Okay dann hab ich hier die Original Tabelle. Etwas weiter vereinfacht. 

In Zeile 17 (A bis E) steht schon das gewünschte Ergebnis. 
V3 = 1 somit kommt dieser Artikel 1 mal vor. Ist diese Bedingung erfüllt, soll mit dem nächsten Artikel fortgefahren werden. Also direkt in die Spalte dahinter mit dem zweiten Artikel aus M4. V4 = 5 damit soll der Artikel 5x hintereinander aufgezählt werden. 

Klingt kompliziert, ist es hoffentlich aber nicht


Angehängte Dateien
.xlsx   Automatic.xlsx (Größe: 13,36 KB / Downloads: 7)
Antworten Top
#5
Hi,

mit ein paar Hilfsspalten:


Angehängte Dateien
.xlsx   Automatic.xlsx (Größe: 14,55 KB / Downloads: 7)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#6
Hallo D...,

wenn die Werte in Spalte T alle größer als 0 sind ginge auch mit einer Hilfsspalte U :

=WENN(A16-$A$16+1>$T$22;"";INDEX($M$3:$M$21;VERGLEICH(A16-$A$16+1;$U$3:$U$21;1)))


Angehängte Dateien
.xlsx   Automatic.xlsx (Größe: 14,33 KB / Downloads: 2)
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antworten Top
#7
Vielen Dank schon mal für die schnelle und unkomplizierte Hilfe. Das hat hervorragend geklappt. 

Jetzt muss ich leider die Liste um eine Spalte erweitern und eine Zusatzfunktion einbauen

In Spalte X befindet sich ein Wert der wieder gibt wie viele Zellen ein Artikel aus Spalte M benötigt. Es soll also abgebildet werden das zum Beispiel M14 3 Zellen benötigt. Diese sollen im Idealfall auch Blank sein. 

Also in dem Beispiel soll der Ergebnis sein C25 = richtig, Dann C26 und C27 leer, dann C28 = M15. Also weiter mit der Indexfunktion 

Wenn ihr mir da noch irgendwie helfen könntet wäre ich sehr dankbar


Angehängte Dateien
.xlsx   Automatic.xlsx (Größe: 15,59 KB / Downloads: 2)
Antworten Top
#8
Hallo D...,

da stimmt etwas an der Anforderung oder an dem Beispiel nicht.

zu:
Zitat:In Spalte X befindet sich ein Wert der wieder gibt wie viele Zellen ein Artikel aus Spalte M benötigt.

Nach der ersten Anfrage und in dem Beispiel benötigt der Artikel aus M5 acht Zellen. Das passt nicht zu der 1 in Segmentweite in X5.
Fehlt da ein "mindestens"?
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antworten Top
#9
Hallo D...,

wenn die Segmentweite die Mindestanzahl für den Artikel vorgibt, könnte man diese Formel nutzen:

=WENN(ODER(A17-$A$17+1>$X$23;(A17-$A$17+2-INDEX($U$4:$U$22;VERGLEICH(A17-$A$17+1;$X$4:$X$22;1)))>INDEX($X$4:$X$22;VERGLEICH(A17-$A$17+1;$X$4:$X$22;1)));"";INDEX($M$4:$M$22;VERGLEICH(A17-$A$17+1;$X$4:$X$22;1)))

hierbe werden die Startpositionen der Artikel (X4:X22) aus den Maxima der Anzahl der Coils und der Segmentweite berechnet:

SUMME(WENN(U$3:U3>W$3:W3;U$3:U3;W$3:W3))+1


Angehängte Dateien
.xlsx   Automatic(3).xlsx (Größe: 17,94 KB / Downloads: 12)
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antworten Top
#10
Wow. Richtig Richtig Richtig gut. 

Ich lad euch alle auf ne kleine Fanta ohne Eis ein. Big Grin 


Vielen Vielen Dank für die Super Hilfe.
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste