Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zelle in Matrix mit Wverweis(?) suchen
#1
Hallo zusammen und einen guten morgen,

ich verzweifle nun schon seit längerem an einer Formel. Habe vorher bereits nach lösungsvorschlägen gesucht jedoch keine gefunden :( 

Ich hoffe ihr könnt mir helfen. 

Folgendes Problem:

Ich habe eine Matrix, in welcher Folgende Daten stehen.

   

In einer anderen Zelle steht der Wert 2547,77. Ich möchte nun in der danebenstehenden Zelle per Formel die zum Wert in der Matrix dazugehörende Zone (100C) anzeigen lassen.

Ich habe es per WVerweis versucht, erhalte jedoch nur den #NV. 

Die Formel sieht Folgendermaßen aus: 

=WVERWEIS(2547,77;B1:F4;1;0)  

Fängt mit B1 an da noch andere Eintragungen irrelevante Eintragungen in der A-Spalte stehen. 



Könnt ihr mir vielleicht helfen?

Ich hoffe hier ist jetzt alles richtig formatiert.


Lieben Gruß,
Antwortento top
#2
Hallo,
so?

Tabelle1

ABCD
1Preisliste - Artikel / Datum
201.01.200924.04.200901.06.2009
3Schwelmer            -   €       25,00 €       29,00 €
4Königsberger       25,00 €       29,00 €       32,00 €
5Krombacher       27,00 €       30,00 €       33,00 €
6
7
8Gültiges Datum:26.04.2009
9Suchkriterium:Königsberger
10Preis:       29,00 €
Formeln der Tabelle
ZelleFormel
B10=WVERWEIS(B8;B2:F5;VERGLEICH(B9;A3:A5;0)+1;WAHR)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#3
Hi und Danke für deine Antwort, leider hat das nicht geholfen denn ich erhalte weiterhin #NV als Ergebnis  :(

Ich hab das mal als Mappe beigelegt, vielleicht hilft das ja  Huh


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 12,5 KB / Downloads: 3)
Antwortento top
#4
Hi,

der VERGLEICH() ergibt, dass es keine identischen Zahlen gibt! Schau dir mal in der Bearbeitungsleiste an, was dort steht, wenn du den Suchbegriff anklickst und was, wenn du die Fundstelle anklickst.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
Stimmt du hast recht, habe als ich es für euch in die Mappe eingetragen habe die ganzen Nachkommastellen der Fundstelle nicht bedacht. Aber selbst wenn man die Fundstelle in die Zelle des Suchbegriffs kopiert funktioniert die Formel nicht. Und ich verstehe ehrlich gesagt auch nicht wieso nicht
Antwortento top
#6
Hi,

schau mal hier rein: https://www.clever-excel-forum.de/Thread...pid=182190 - das dürfte deinem Problem entsprechen.

Schau mal, ob du die Vorschläge dort auf dein Anliegen anpassen kannst. Wenn nicht, melde dich wieder - Lösung habe ich. Aber selber drauf kommen, macht doch auch Spaß, oder?
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#7
Puh das kann doch nicht sein, dass es so eine Ellenlange Formel benötigt, um mir den Zelleninhalt der 1. Zeile zu einem Wert der in der selben Matrix ist anzeigen zu lassen o.O

Versuche es dann mal nach den Angaben in dem Thread, hoffe es klappt mit mienen begrenzten Skills - danke dir vielmalsSmile
Antwortento top
#8
Ich habe gerade meinen Beitrag ergänzt und du gleichzeitig geantwortet.

Nein, so lang ist die Formel nicht!
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#9
Puh ich kriegs nicht hin....Ich weiß zwar, dass ich nicht so gut mit Excel bin aber dass ich das nicht schaffe frustriert mich jetzt doch schon  22
Antwortento top
#10
Hi,

jeder fängt mal an. Wink

Hier mein Vorschlag:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFG
1KW100A100B100C100D101A101B
249/193448,282586,211724,141724,140,002732,24
350/1914749,261111,000,001474,930,00834,03
451/196369,430,002547,770,001111,002205,07
5
6
7WertZone
81111,00100B
9101A
10
11
12

ZelleFormel
B8=WENNFEHLER(INDEX($A$1:$G$1;AGGREGAT(15;6;SPALTE($B$1:$G$4)/($B$1:$G$4=$A$8);ZEILE(A1)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Ich habe die Formel flexibel gestaltet, damit du sie runterziehen kannst, um alle Zonen anzuzeigen, die den gleichen Wert (wie z.B. die Nullwerte in deinem Beispiel) haben.

Achte unbedingt darauf, die Werte und die Suchbegriffe gleichzuschalten. Ich vermute mal, du beziehst deine Werte über eine Formel. Dann solltest du sie runden:
Code:
=RUNDEN(deine_Formel;Anz. Stellen)
Dann passt es auch, wenn du den Suchwert manuell mit denselben Dezimalstellen eingibst.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Excel_Anfänger
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste