Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zeitberechnung
#1
Schönen guten Morgen!!!!

Ich stoße leider wieder mal an meine Grenzen und finde leider auch nichts passendes aus den bereits vorhandenen Themen.
Ich möchte aus mehreren Zeiten die Stunden und Minuten berechnen, die in ein vorgegebenes Zeitfenster fallen.
Also ich habe zum Beispiel ein Zeitfenster von 17.02.2020 05:00 Uhr bis 18.02.2020 17:00 Uhr
und möchte aus mehreren Zeiten die Summe dieser Zeiten erfassen.
Am besten erklärt ist es vielleicht durch die Excel-Datei, die ich für meine Frage angelegt habe. Es soll nämlich auch erkennen, wenn die Endzeit kleiner ist als die Anfangszeit, die Endzeit auf den nächsten Tag fällt:
17.02.2020      07:00 Uhr - 05:00 Uhr (22Stunden)
17.02.2020      08:00 Uhr - 12:00 Uhr (4Stunden)
17.02.2020      19:00 Uhr - 1:00 Uhr (6Stunden)
17.02.2020      04:00 Uhr - 06:00 Uhr (1Stunde)

Hier z. Beispiel sollte es das Ergebnis: 33 Stunden ergeben.

Klar könnte ich alles mit Hilfstabellen lösen, aber gibt es vielleicht einen einfacheren Weg oder Lösung?

Danke an alle, die mir helfen wollen!

.xlsx   Zeitfensterrechnung.xlsx (Größe: 8,46 KB / Downloads: 10)
lg
Antwortento top
#2
=REST(C3-B3;1)
Zum runter kopieren in D3
Anschließend Summe bilden Zellformat 
[hh]:mm
Gruß Holger
Antwortento top
#3
B13: 

=SUMME(
WENNFEHLER(EXP(LN(C$11-B$11-
WENNFEHLER(EXP(LN(C$11-(A3:A7+C3:C7+(C3:C7<B3:B7))));0)-
WENNFEHLER(EXP(LN((A3:A7+B3:B7)-B$11));0)));0))

in älterem Excel als Matrixformel (!) abzuschließen.

Hinweis: Bei Deinen Zahlen kommt korrekt nur 8 statt 20 Std. raus. Für 20 Std. musst Du auch in Zeile 6 und 7 mit 17.2.2020 beginnen, nicht mit 18.2.2020.
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • mrhayabusa
Antwortento top
#4
Danke, ja stimmt....habe das Zeitfenster falsch gestaltet, sollte bis 19.02.2020 04:00 Uhr bedeuten

Probiere es gleich mal aus, danke vorerst
Antwortento top
#5
Dann landen wir bei 22 statt 20 Stunden.
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • mrhayabusa
Antwortento top
#6
Danke nochmal vielmals...die Formel tut genau was ich brauche....

...ehrlich gesagt verstehen tue ich sie aber genau 0 15
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste