Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zeichen in Zelle mit Bedingung zählen
#1
Hallo zusammen,

ich benötige bitte eure Hilfe.

Ich möchte Zeichen in einer Zelle zählen allerdings nur wenn eine weitere Bedingung erfüllt wurde.

   

Es müsste daher die Funktion "LÄNGE" in Kombination mit "ZÄHLENWENNS".

Vielen Dank vorab, ich hoffe alle wichtigen Infos sind drinnenSmile

Lg
Antwortento top
#2
Sehe keine Datei...Datei ohne sensible Daten ist immer am besten, anstatt Bild.
So kann man am besten sehn wo der Fehler liegt, in der Eingabe oder Blatt.
...habe es mir sagen lasen 19
Antwortento top
#3
Ich bekomme es ja nicht hin, deshalb habe ich das Beispielbild beigefügt und brauche ja HilfeSmile

Mein erster Ansatz war wie folgt für Zeile B13 im Bild: "=ZÄHLENWENNS(A2:A6;"R3";B2:B6;"★★★★")" aber damit zählt er leider nur die 4 Sterne und gibt mir das Ergebnis "1" aus obwohl es ja 7 sein müssten.
Antwortento top
#4
Moin!
AB
1R1x
2R2xx
3R3x
4R2x
5R1xxxxx
6
7R16
8R23
9R31

ZelleFormel
B7=SUMMENPRODUKT((A$1:A$5=A7)*LÄNGE(B$1:B$5))
B8=SUMMENPRODUKT((A$1:A$5=A8)*LÄNGE(B$1:B$5))
B9=SUMMENPRODUKT((A$1:A$5=A9)*LÄNGE(B$1:B$5))

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
[-] Folgende(r) 1 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • rodeoric
Antwortento top
#5
Hallo @RPP63/Ralf,



vielen Dank für deine Mühe.



Leider funktioniert das so bei mir überhaupt nicht.



Ich habe die Mappe mal angehangen, vielleicht findest Du den FehlerSmile


Lg


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 9,41 KB / Downloads: 3)
Antwortento top
#6
Das wird dir Probleme bereiten, denn der Stern(*) ist das Stellvertretersymbol für die Textsuche, also werden mit dem (*) auch andere Textfelder addiert.
Benutze ein anderes Symbol, das nicht als Stellvertretersymbole benutzt wird.
 
Beispiel: ? (Fragezeichen)


Ansonsten sllte es mit dieser formel gehen (mit sternchen glaube ich nicht):
ZÄHLENWENN(B2:B6;"?")

Danke,
Niko 78
Antwortento top
#7
Natürlich funktioniert das!
Du musst natürlich richtig abschreiben:
AB
1R1
2R2★★
3R3
4R2
5R1★★★★★
6
7R16
8R23
9R31

ZelleFormel
B7=SUMMENPRODUKT((A$1:A$5=A7)*LÄNGE(B$1:B$5))
B8=SUMMENPRODUKT((A$1:A$5=A8)*LÄNGE(B$1:B$5))
B9=SUMMENPRODUKT((A$1:A$5=A9)*LÄNGE(B$1:B$5))

@Nico:
★ <> *
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
[-] Folgende(r) 2 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • rodeoric, Niko
Antwortento top
#8
imo funktioniert die Formel von Ralf, sofern man die Referenzen wie gezeigt eingibt:

R1 ★
R2 ★★
R3 ★
R2 ★
R1 ★★★★★

R1 6

=SUMMENPRODUKT((A$1:A$5=A7)*LÄNGE(B$1:B$5))


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 5,3 KB / Downloads: 4)
[-] Folgende(r) 2 Benutzer sagt Danke an Fennek für diesen Beitrag:
  • rodeoric, Niko
Antwortento top
#9
Ah Tatsache, das funktioniert blendend von Ralf.

Ich versuche das jetzt mal auf meine Excel anzuwenden, absolut Klasse.

Vielen lieben Dank @RalfSmile
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste