Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zeichen einer Zahl zuordnen
#1
Hallo,

ich möchte eine Bewertungstabelle erstellen, in welcher man mit ++, +, 0, -, -- bewerten kann.
++ soll dabei = 2 sein
+ = 1
- = -1
-- = -2



Jemand 'ne Idee wie man vorgeht?

Vielen Danke und Grüße


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 8,27 KB / Downloads: 7)
Antwortento top
#2
Hallo,

im Interesse einer späteren Auswertung würde ich es bei den Zahlen belassen. Zumal Plus- und Minuszeichen von Excel anderweitig belegt sind.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Hi,

das gleiche Thema wird augenblicklich hier https://www.clever-excel-forum.de/thread...#pid157835 behandelt.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.zitate.net
Antwortento top
#4
Hallo

Entweder mit dem SVERWEIS():

Code:
=SVERWEIS(A1;$J$1:$K$4;2;FALSCH)

Oder so:

Code:
=--(LINKS(A1)&LÄNGE(A1))
Grüsse
Detlef

Bitte keine PN!
Seit Nikolaus 2012 mit Excel 2010. Seit Ostern 2015 mit Office 365
Antwortento top
#5
Hallo, ich dachte hier so..:

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
9GewichtungBewertung
109++
118+
127-
136-
145++
154-
163+
172+
181-
19Gewichtete Summe "+"41
20Gewichtete Summe "-"-18

ZelleFormel
B19=SUMMENPRODUKT(LÄNGE($B$10:$B$18)-LÄNGE(WECHSELN($B$10:$B$18;"+";));$A$10:$A$18)
B20=-SUMMENPRODUKT(LÄNGE($B$10:$B$18)-LÄNGE(WECHSELN($B$10:$B$18;"-";));$A$10:$A$18)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • KeinExcelGuru
Antwortento top
#6
Oh, die Datei hatte ich doch glatt übersehen.


Code:
=SUMMENPRODUKT((LINKS(B10:B18)&LÄNGE(B10:B18))*A10:A18*(LINKS(B10:B18)="+"))
=SUMMENPRODUKT((LINKS(B10:B18)&LÄNGE(B10:B18))*A10:A18*(LINKS(B10:B18)="-"))
Grüsse
Detlef

Bitte keine PN!
Seit Nikolaus 2012 mit Excel 2010. Seit Ostern 2015 mit Office 365
[-] Folgende(r) 1 Benutzer sagt Danke an Hydronaut für diesen Beitrag:
  • KeinExcelGuru
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste