Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zahlen löschen
#1
Hallo allerseits,
ich stehe mal wieder auf dem Schlauch und kriege es nicht gebacken.
Wie kann ich aus den Zahlenkombinationen 01.01.1000, 02.01.1000 usw., den Spalten A1 bis C50
die 01.01. durch eine Formel entfernen, so dass nur noch die letzen 4 Zahlen stehen?
Freue mich auf euren Vorschlag.
Gruss Martin


Angehängte Dateien
.xlsx   01.01. löschen.xlsx (Größe: 8,93 KB / Downloads: 11)
Antwortento top
#2
Hallo,

=WENN(TEXT(A1;"JJJJ")=A1;RECHTS(A1;4);TEXT(A1;"JJJJ"))

Gruß Uwe
[-] Folgende(r) 1 Benutzer sagt Danke an Kuwer für diesen Beitrag:
  • merkurus
Antwortento top
#3
Danke Uwe,
die Formel funktioniert nicht so wie ich dies möchte. Es sind keine Datum, sondern Zahlenkombinationen.
In der Tabelle soll nur  01.01. gelöscht werden, so dass am Ende nur noch die letzten 4 Zahlen stehen.
Aus 01.01.1000 usw. wird dann 1000. Alle andern sollen nicht verändert werden.
Gruss Martin
Antwortento top
#4
Luna und Merkurus...
Jetzt fehlt nur noch unsere Venus Sabina. Wink
Es reicht doch RECHTS(A1;4)*1

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#5
Hallo Ralph,
habe hier gelb markiert, welche Zahlenkombination geändert werden dürfen, alle andern nicht.
Im Original sind die Zellen nicht gelb markiert.
Gruss Martin
   
Antwortento top
#6
Hallo Martin,

so hab's ich verstanden:
Arbeitsblatt mit dem Namen 'Tabelle2'
AB
101.01.10001000
202.01.100102.01.1001
302.01.100202.01.1002
401.01.10031003

ZelleFormel
B1=WENN(LINKS(A1;5)="01.01";RECHTS(A1;4);A1)
B2=WENN(LINKS(A2;5)="01.01";RECHTS(A2;4);A2)
B3=WENN(LINKS(A3;5)="01.01";RECHTS(A3;4);A3)
B4=WENN(LINKS(A4;5)="01.01";RECHTS(A4;4);A4)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#7
B1: =WECHSELN(A1;"01.01.";)
Antwortento top
#8
Hallo Günter,
du hast es richtig verstanden und mein Problem gelöst. 78
Besten Dank für deine Mühe.
Martin

Danke LCohen,
auch deine Formel funktioniert.  78
Gruss Martin
Antwortento top
#9
Was spricht eigentlich gegen strg+h?
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#10
(03.08.2020, 13:47)luna101 schrieb: Hallo Günter,
du hast es richtig verstanden und mein Problem gelöst.78
Was aber, wenn die Zelle leer ist?
Besten Dank für deine Mühe.
Martin

Danke LCohen,
auch deine Formel funktioniert.  78
Was aber, wenn die Zelle leer ist?
Gruss Martin
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste