Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zahl wird falsch ausgeben von Wawi
#1
Servus zusammen,

ich habe folgendes Problem.

Die Wawi der Arbeit gibt aus einer Statistik Prozentzahlen mit -% aus, wie z.B. 12,35-%
Mit dieser Zahl kann Excel nicht wirklich was anfangen, richtig wäre ja -12,35%
Hat jemand einen schnelle Lösung mit welche ich das -% fix an die richtige stelle bekommen, also minus/wert/prozent?

Versuchte habe ich mit der Ersetzten Funktion suche 12,35-%
Ersetze mit -[wert]%, Ergebnis ist jedoch dann nur noch -%

Wenn ich die Zahl als eine Prozentzahl formatiere, macht Excel nichts, es bleibt bei 12,35-%

Dank für eure Hilfe :)
Antwortento top
#2
Moin!
Aufgrund der erschöpfenden Beschreibung:

AB
112,35-%-12,35%

ZelleFormatWert
B10,00%-0,1235

ZelleFormel
B1=-WECHSELN(A1;"-";"")

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#3
Geht auch komplizierter Angel 
Sind es immer -% oder auch mal normale ^^

Formatierung der Zelle:

Standard "%"

Formel:

=WENN(ISTFEHLER(SUCHEN("-";A1;1));A1*100;LINKS(A1;LÄNGE(A1)-2)*-1)
Antwortento top
#4
(09.01.2020, 20:45)Basisa schrieb: ...
Formel:

=WENN(ISTFEHLER(SUCHEN("-";A1;1));A1*100;LINKS(A1;LÄNGE(A1)-2)*-1)

Hallo, eher so, oder?

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
112,35-%-12,35%
213,50%13,50%

ZelleFormel
B1=WENN(ISTFEHL(SUCHEN("-";A1;1));A1;LINKS(A1;LÄNGE(A1)-2)*(-1%))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#5
Egal wie, geht ja beides!
Bei der anderen eben die Zelle formatieren! ;)
Antwortento top
#6
Hallo, oder einfach mit Power Query einlsen Datentyp auf Prozent stellen und wieder ausgeben...

(09.01.2020, 21:30)Basisa schrieb: Egal wie, geht ja beides!
Bei der anderen eben die Zelle formatieren! ;)


Hallo, naja nicht ganz, wenn ich 13,5 so formatiere wie du beschrieben hast sieht es nur nach einem Wert in Prozent aus; ist es aber nicht!!!!
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#7
Stimmt, finde es besser mit, ich nenne es mal normalen Werten zu arbeiten und nicht diese 0,0321 blablaSmile

Aber stimmt, sollte man wissen bevor man sich wundert wenn man damit rechnen will!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste