Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zählenwenns mit Datumfunktion (von - bis)
#1
Hallo Leute,

seit mehreren Stunden sitze ich vor einem Problem.

Aktuell habe ich folgende Formel 

Code:
=ZÄHLENWENNS($K$4:$K$9397;">=01.01.2021";
$K$4:$K$9397;"<=31.12.2021";
!$D$4:$D$9397;Prov_Ber!$A$20;$Q$4:$Q$9397;"")

Dieser Code funktioniert auch.
Nur möchte ich jetzt in Zelle "K3" das entsprechende Jahr angeben.
Also wie hier "2021".
Sobald ich das Jahr in Zelle K3 ändere, soll immer vom 01.01.XXXX - 31.12.XXXX abgesucht werden.

Ich habe es bis jetzt nur mit 
Code:
=ZÄHLENWENNS($K$4:$K$9397;DATUM(K3;1;1);
geschafft.
Also einen bestimmten Tag abzusuchen.
Allerdings bekomme ich es nicht hin, einen Suchbereich einzugeben.

Könnt Ihr mir helfen ?!?

Vielen Dank im voraus
Antwortento top
#2
Hola,


Code:
...;">="&datum(K3;1;1);......;"<="&datum(K3;12;31);...

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • PkrFc07
Antwortento top
#3
Hallo,

versuche es mal so: =SUMMENPRODUKT((JAHR($K$4:$K$9397)=K3)*1)
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#4
(12.10.2020, 11:48)steve1da schrieb: Hola,


Code:
...;">="&datum(K3;1;1);......;"<="&datum(K3;12;31);...

Gruß,
steve1da


Vielen Dank, dass ist es. So funktioniert es perfekt.
Mir waren die " und das & nicht bewusst, bzw. wusste ich die genaue Anordnung nichtSmile
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste