Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zählenwenn mit Multiplikation und mit Matrix?
#1
Hallo,

ich habe ein hoffentlich kleines Problem, jedoch bekomme ich es leider nicht hin und habe auch nichts dazu gefunden....
Ich habe eine größere Tabelle in dieser möchte ich in einem Bereich Zählen wie oft dieser Wert vorkommt und dann diesen Wert multiplizieren mit einem Faktor in der gleichen Zeile.
Habe ein Beispiel angehängt.
Theoretisch könnte ich dass wir folgt machen:
=(ZÄHLENWENN(C5:AE5;F2)*A5)+ZÄHLENWENN(C6:AE6;F2)*A6 + ZÄHLENWENN....+ ZÄHLENWENN etc.
Dies ist aber leider sehr müßig immer einzutippen.
Gibt es hier eine schnellere Variante? Ich habe es mit der Matrix probiert, es jedoch nicht hinbekommen....

sorry dass ich euch hiermit belästige, aber ich bekomme es leider nicht hin.

Vielen Dank schon im Voraus für euere Antworten.

Gruß Daniel


Angehängte Dateien
.xlsx   Excel Anfrage.xlsx (Größe: 10,84 KB / Downloads: 8)
Antwortento top
#2
Hi Daniel,

ich würde es mit einer Hilfsspalte, die du ausblenden kannst, lösen:
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAF
2Summe von10=290
3
4MultiplikationZählen WennHS
5201010101010101010555555555555555555555160
6102020202020202020202010101010101010101010101010555181818130
73030303030303030303535151515151515151515151515155553131310
82540404040404040405050202020202020202020202020205554444440
91550505050505050506565252525252525252525252525255555757570
103560606060606060608080303030303030303030303030305557070700
113070707070707070709595353535353535353535353535355558383830
12208080808080808080110110404040404040404040404040405559696960
13409090909090909090125125454545454545454545454545455551091091090
1435100100100100100100100100140140505050505050505050505050505551221221220
1525110110110110110110110110155155555555555555555555555555555551351351350
1645120120120120120120120120170170606060606060606060606060605551481481480
1740130130130130130130130130185185656565656565656565656565655551611611610
1830140140140140140140140140200200707070707070707070707070705551741741740
1950150150150150150150150150215215757575757575757575757575755551871871870

ZelleFormel
H2=SUMME($AF$5:$AF$19)
AF5=ZÄHLENWENN($C5:$AD5;$F$2)*A5
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallo,

=SUMMENPRODUKT(MMULT(N(C5:AE19=F2);MODUS.VIELF({1;1}*SPALTE(C5:AE19))^0);A5:A19)

Gruß
Advanced Excel Techniqueshttp://excelxor.com/
Antwortento top
#4
Hi

=SUMMENPRODUKT((C5:AE19=F2)*A5:A19) 

Gruß Elex
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • Daniel L.
Antwortento top
#5
Thumbs Up 
Hallo,

vielen, vielen Dank. Genau das habe ich gesucht  Thumps_up Thumps_up

Gruß Daniel
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste