Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zählen von unterschiedlichen Werten mit einer Bedingung
#1
Hallo zusammen,

möchte gerne das in der Zelle AF3 die erreichte Punktezahl errechnet wird, wenn in der Zelle ein "R" eingetragen ist.

Jede Frage hat ihre Wertigkeit = Angerechnete Punkte (Zelle B2:AE) 

Meine Formel hat irgendwo ein Fehler. 

Kann mir jemand weiterhelfen?

Gruß Sebastian


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 20,46 KB / Downloads: 5)
Antwortento top
#2
Verwende sumproduct.
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antwortento top
#3
Hallo,

Tabelle1

ABCDEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAF
1Frage123456789101112131415161718192021222324252627282930Pkt.
2Angerechnete Punkte31421121341321423132112423113264
3Mitarbeiter 1RRR8
Formeln der Tabelle
ZelleFormel
AF3=SUMMENPRODUKT((B3:AE3="R")*(B2:AE2))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

[-] Folgende(r) 1 Benutzer sagt Danke an marose67 für diesen Beitrag:
  • alpimd
Antwortento top
#4
Hey,

manchmal ist die Lösung doch so einfach, habe zu kompliziert gedacht.

Ich danke euch für die Lösung.

Gruß Sebastian
Antwortento top
#5
Hallo, alternativ ohne Array-Formel (SUMMENPRODUKT() ist eine Array-Formel per Definition)...: Obwohl das Summieren statt Zählen ist..!!!

PHP-Code:
=SUMME(INDEX(B2:AE2*(B3:AE3="r");)) 

oder ..:

PHP-Code:
=SUMMEWENN(B3:AE3;"r";B2:AE2
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste