Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

ZÄHLEWENNS-Funktion Fehlermeldung
#1
Hallo miteinander,

ich verwende momentan folgende Funktion in Kombination mit einer benutzerdefinierten Datenüberprüfung:

=(ZÄHLENWENN($C$7:$C$74;C7))<2

Soweit funktioniert das ganz gut. Mir ist nur aufgefallen, dass die Zellen C6, C11, C20, C35, C52 und C62 nicht mit durchsucht werden dürfen.
Im Internet bin ich auf die ZÄHLENWENNS-Funktion gestoßen, mit welche man ja mehrere Kriterien und Bereiche verknüpfen kann. Meine Lösung funktioniert leider nicht.

=(ZÄHLENWENNS($C$7:$C$7;C7;$C$12:$C$16;C7;$C$21:$C$31;C7;$C$36:$C$48;C7;$C$53:$C$58;C7;$C$63:$C$74;C7))<2 

Da spuckt mir Excel immer folgenden Fehler aus: "Die Funktion untersucht gerade einen möglichen Fehler."

kann mir jemand einen alternativen weg aufzeigen, oder wie ich den Fehler beseitigen kann, ich finde ihn einfach nicht.


Grüße,
sa1bot
Antwortento top
#2
Mit deiner Formel kommst du nicht weit, da Zählenwenns bei den Kriterien wie ein UND funktioniert 
du musst 

=(ZÄHLENWENNS($C$7:$C$7;C7))<2+zählenwenns($C$12:$C$16;C7)<2....... erstellen 
Antwortento top
#3
Danke für den Tipp! Ich habe das gleich mal ausprobiert und es hat leider nicht funktioniert. Bei mir kommt dann die Fehlermeldung: "Der angegebene benannte Bereich wurde nicht gefunden".
Eigentlich sollte es den Bereich in der Tabelle aber geben.
Weißt du woran das liegen kann?

EDIT: ich habe den Fehler gefunden. Jedoch funktioniert die Funktion nicht jetzt nicht so, wie es funktionieren sollte.
Eigentlich sollte in meine Zelle eine Zahl eingeben können und gebe ich die selbe Zahl in der Spalte noch einmal ein, müsste über die Datenüberprüfung eine Fehlermeldung kommen, dass diese zahl schon eingegeben wurde.
Jetzt ist es aber so, dass ich eine Zahl eingebe und sofort eine Fehlermeldung kommt, obwohl in der Spalte(Gültigkeitsbereich) noch keine Zahl eingetragen ist.
Antwortento top
#4
Hola,

bislang hast du erfolgreich verschwiegen dass du mit benannten Bereichen arbeitest.
Kurz gegooglet:
https://www.herber.de/forum/archiv/1472t...gquot.html

Gruß,
steve1da
Antwortento top
#5
Danke, über diesen Post bin ich auch gestoßen und konnte mein Problem beheben. Leider ist nun ein neues Problem, wie im EDIT beschrieben aufgetreten.
Antwortento top
#6
Hola,

wir brauchen dazu die aktuelle Datei oder eine identisch aufgebaute Beispieldatei wo das so auftritt.

Gruß,
steve1da
Antwortento top
#7
Hier habe ich mal eine Beispieldatei hochgeladen, die der Originaldatei sehr ähnelt (nur gekürzt). Bisher ist die Formel im Blatt Januar und November jeweils in der Zelle C7 über die Datenprüfung eingefügt.


.xlsx   Anw_Bsp.xlsx (Größe: 88,91 KB / Downloads: 5)

Ich hoffe das du/ihr damit etwas anfangen könnt.
Antwortento top
#8
Hallöchen,

nur mal ein Gedanke.

Du schreibst
Zitat:Jetzt ist es aber so, dass ich eine Zahl eingebe und sofort eine Fehlermeldung kommt, obwohl in der Spalte(Gültigkeitsbereich) noch keine Zahl eingetragen ist.

Eventuell musst Du mal Deine Bedingung überdenken. Hier kann ich z.B. so lange was eintragen, wie einschließlich meiner Eingabe im Bereich A1:A3 weniger als 2x die 2 steht. Steht keine 2, kann ich eingeben, was ich will. Steht eine 2 im Bereich A2;A3, kann ich in A1 alles eingeben außer einer 2...

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
11FALSCH
22
32
ZelleFormel
C1=ZÄHLENWENN(A1:A3;2)<2
ZelleGültigkeitstypOperatorWert1Wert2
A1Benutzerdefiniert=ZÄHLENWENN(A1:A3;2)<2
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste