Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wort in Zelle suchen und wiedergeben
#1
Hallo liebe Leute,
ich benötige eine Formel, welche folgendes möglich macht.

in Zelle 1 steht folgender Eintrag: Belgium (D/O), France (D/O), Luxembourg (D)

ich würde gerne in der Zelle daneben die Wörter (Länder) bzw. zumindest eins davon, welche ein O in der nachfolgenden Klammer aufweisen:
Bspw. Ausgabe Zelle 2: Belgium, France

mit =LINKS([Zelle 1];FINDEN("O)";[Zelle 1])-2) ist leider nur die Ausgabe Belgium möglich. Bzw. stösst die Formel an ihre Grenzen wenn in Zelle 1 bsp. Denmark (D), Greece (D), Italy (O) steht, dann wäre die Ausgabe: Denmark (D), Greece (D), Italy.

Kurzum zusammengefasst ich bräuchte eine Formel die ein Wort vor den gesuchten Wert (hier "O)") ausgibt.

Vielen Dank im Voraus für Eure Ratschläge!
lg Gregor
Antwortento top
#2
Hi

Formel wird hier recht umständlich sein.
Ich würde es dir per VBA oder PowerQuery anbieten.

Gruß Elex

Mit PQ

.xlsx   Mappe1.xlsx (Größe: 17,8 KB / Downloads: 6)
Antwortento top
#3
Hallo,

Matrixformel (STRG+UMSCHALT+EINGABE):

Code:
=WENNFEHLER(TEXTVERKETTEN(", ",,GLÄTTEN(LINKS(WECHSELN(XMLFILTERN("<a><b>"&WECHSELN(A1,",","</b><b>")&"</b></a>","//b[contains(text(),""O)"")]")," ",WIEDERHOLEN(" ",99)),99))),"")

Grüß
Advanced Excel Techniqueshttp://excelxor.com/
Antwortento top
#4
Vielen Dank,
puh! die Matrix-formel sieht ganz schön kompliziert aus =D
habe diese jetzt einfach in das entsprechende feld eingefügt und A1 mit der Textfeldadresse ausgetauscht. Nach STRG+UMSCHALT+EINGABE
zeigt mir Excel ein problem "Sie möchten gar keine Formel eingeben?" und markiert ,,GLÄTTEN

VBA und Macros darf ich leider nicht auf dem Firmenrechner nutzen - trotzdem vielen Dank für die Umstände!!

lg Gregor
Antwortento top
#5
Hallo

mein Vorschlag hat nichts mit VBA und Makro zu tun.

PowerQuery bzw. in Excel 2016 Daten abrufen und transformieren.
https://support.microsoft.com/de-de/offi...e18d75b4de

Gruß Elex
Antwortento top
#6
Entschuldigen Sie. Kommas anstelle Semikolons.

Code:
=WENNFEHLER(TEXTVERKETTEN(", ";;GLÄTTEN(LINKS(WECHSELN(XMLFILTERN("<a><b>"&WECHSELN(A1;",";"</b><b>")&"</b></a>";"//b[contains(text(),""O)"")]");" ";WIEDERHOLEN(" ";99));99)));"")

Gruß
Advanced Excel Techniqueshttp://excelxor.com/
Antwortento top
#7
Hallo - vielen Dank für die Korrektur - leider die Formel bei mir immer noch nicht (siehe Anlage).
lg Gregor


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#8
Ihrem Profil steht daß Sie Excel 2016 haben? Die deutsche Version, richtig?

Grüß
Advanced Excel Techniqueshttp://excelxor.com/
Antwortento top
#9
Moin

TEXTVERKETTEN() gibt es erst ab Excel 2019.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#10
(16.09.2020, 15:08)shift-del schrieb: Moin

TEXTVERKETTEN() gibt es erst ab Excel 2019.

Ja, Sie haben recht...
Advanced Excel Techniqueshttp://excelxor.com/
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste