Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wörter vergleichen
#1
Hallo Zusammen.

Wie kann ich in excel für zwei Wörter finden wie viel gleiche Buchstaben haben?
z.B. Tag, Nacht = 2 (t,a)
Auftrag, Banane = 2 (a,a)

Danke im Voraus
Antwortento top
#2
C1: =SUMMENPRODUKT(WENN(
LÄNGE(A1)-LÄNGE(WECHSELN(GROSS(A1);ZEICHEN(ZEILE($65:$90));))<
LÄNGE(B1)-LÄNGE(WECHSELN(GROSS(B1);ZEICHEN(ZEILE($65:$90));));
LÄNGE(A1)-LÄNGE(WECHSELN(GROSS(A1);ZEICHEN(ZEILE($65:$90));));
LÄNGE(B1)-LÄNGE(WECHSELN(GROSS(B1);ZEICHEN(ZEILE($65:$90));)))*(((
LÄNGE(A1)-LÄNGE(WECHSELN(GROSS(A1);ZEICHEN(ZEILE($65:$90));)))*(
LÄNGE(B1)-LÄNGE(WECHSELN(GROSS(B1);ZEICHEN(ZEILE($65:$90));))))>0))

äöüß sind nicht dabei; die zählst Du händisch dazu. Als Finne (Mäkärainen) hast Du schlechte Karten, aber dann kann man Dich immer noch am Heck montieren.
Antwortento top
#3
Moin

Für Anwender mit einer aktuellen Excel-Version:
Code:
=SUMME(--ISTZAHL(SUCHEN(TEIL(A1;SEQUENZ(LÄNGE(A1));1);B1)))

=SUMME(ZÄHLENWENNS(B1;"*"&TEIL(A1;SEQUENZ(LÄNGE(A1));1)&"*"))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
r a g s h e l
B a n a n e n p f l ü c k e r

zeigt bei mir 7, bei Dir jeweils 8 an, shift-del.
Antwortento top
#5
Danke für Antwort, sequenz Funktion habe ich leider nicht.

LCohen: Deine Funktion funktioniert bei manchen Reihen, bei manchen nicht.
Ich weiss nicht was habe ich falsch gemacht.
Antwortento top
#6
Hallo,

Array-Formel**:

=SUMME(REST(KKLEINSTE(100*ZEILE($1:$26)+LÄNGE(A1:B1)-LÄNGE(WECHSELN(GROSS(A1:B1);ZEICHEN(ZEILE($65:$90));""));2*(ZEILE($1:$26)-1)+1);100))

Gruß


**STRG+Umschalt+Eingabe
Advanced Excel Techniqueshttp://excelxor.com/
Antwortento top
#7
UDF:

Code:
Function F_snb(sn)
  sn = sn
  For j = 1 To Len(sn(1, 1))
      n = n - (InStr(1, sn(2, 1), Mid(sn(1, 1), j, 1), 1) > 0)
  Next
  F_snb = n
End Function


PHP-Code:
=F_snb(A1:A2
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste