Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wiederholender Speiseplan
#1
Guten Abend,

ich versuche gerade über Excel mir einen Speiseplan zu erstellen, der sich alle 6 Wochen wiederholt.
Ich habe es mir folgendermaßen gedacht. Auf der Übersichtsseite ist die Tabelle zu sehen. Das Datum wird mit der Formel Heute() erzeugt.
Ziel ist es, dass die Zelle durch eine Formel eine überprüfung macht, ob die Kalenderwoche, die mit erzeugt wird und der Wochentag, der auch erzeugt wird übereinstimmt, und dann den Wert aus einem anderen Tabellenblatt übernimmt, wenn dies nicht übereinstimmt, dann den wert von der anderen kalenderwoche, und wenn dieser auch nicht stimmt, dann aus der anderen usw.
Es gibt 6 verschiedene Pläne für jede Kalenderwoche, d.h. Plan 1 soll für KW 1, 7, 13, 19....), Plan 2 für 2, 8, 14,.... usw.
Innerhalb dieser Pläne gibt es 7 Unterpläne für die einzelnen Wochentage.

Mein Ansatz war, dass ich in einer Zelle mit einer Wenn abfrage starte, dass die Kalenderwoche, die in der Zelle B2 erzeugt wurde entweder 1 oder 7, 13, 19, 25.... ist und der Wochentag aus B4 der selbe ist wie der in Tabellenblatt 3, dann soll der Wert aus der entsprechende Zelle vom Tabellenblatt 3 genommen werden, wenn dieser nicht stimmt, dann, wenn Kalenderwoche 2,...... und wochentag stimmen, den wert aus der entsprechende Zelle nehmen usw.

Testweise habe ich damit begonnen, eine einfache Abfrage zu starten. Wenn es zutrifft, dann soll der Wert angezeigt werden, ansonsten soll die Zelle leer bleiben. Leider habe ich in der Formel ein FEhler, dass er mir als Rückmeldung #WERT ausgibt. Habt ihr eine Idee, wie die Formel korrigiert oder angepasst werden muss, damit es funktioniert?

=WENN((KALENDERWOCHE(B2;21)=1*(ODER(7;13;19;25;31;37;43;49)))*UND(B4)=Wochenpläne!F3;Wochenpläne!A3;"")

Vielen Dank für die Hilfe und Tipps

Lg Kopiniko


Angehängte Dateien
.xlsx   Speiseplan.xlsx (Größe: 98,66 KB / Downloads: 8)
Antwortento top
#2
Hallo Kopiniko,

Du hast 6 (0-5) Speisepläne je Mo-So.  Rechne dann mit  "= Rest( KW; 6)", dann hast du den richtigen Speiseplan. Jetzt nur noch Mo-So des entsprechenden Planes anzeigen.

Sigi
[-] Folgende(r) 1 Benutzer sagt Danke an Sigi.21 für diesen Beitrag:
  • Kopiniko
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste