Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Werte nach Datum suchen / INDEX, MAXWENN
#1
Hallo,
 
Anbei mein Problemfall, mit der inbrünstigen Bitte um Hilfe;

.xlsx   Arbeitsmappe_BOXID.xlsx (Größe: 80,42 KB / Downloads: 4)

Ich habe eine Kontrollgruppe mit durchlaufenden, einmaligen Codes (für Behälter) und zu unterschiedlichen Zeitpunkten eine sog. Arbeitsvorlage.
 
DIe Arbeitsvorlage gibt den Stand "jetzt" mit dem Aufenthaltsort aller Behälter an - Kunde, Adresse, AuftragsID (siehe Spalten Kontrollgruppe). In einem Zeitraum von... bis... Heißt, die Codes tauchen unter Box-ID mit unterschiedlichen Daten bei unterschiedlichen Kunden auf.

Ich möchte nun, dass sich die Formel in der Kontrollgruppe für jeden Behälter BoxID den letzten Status (Adresse, Kunde, etc.)  gemäß dem jüngsten Datum in der Arbeitsgruppe zieht.
 
Ich habe bisher die Formel
 
=INDEX($M$4:$Q$10148;VERGLEICH((MAXWENNS($Q$4:$Q$10148;$M$4:$M$10148;"*"&$A3&"*"));$Q$4:$Q$10148;0);3)
 
Aber ich bekomme nicht das gewünschte Ergebnis; denn (gelb und blau markiert) zieht sich die Formel anscheinend nur die Daten (Kunde, Adresse, etc.) aus der Zeile des ersten gefundenen MAX-Datums, aber nicht im Abgleich, im Zusammenhang mit der jeweiligen BOX-ID
Oder anders gesagt: Ziel ist – Finde BoxID aus der Kontrollgruppe (A3 …) in der Arbeitsvorlage mit dem jüngsten Datum und gib die Werte (ID, Kunde, Adresse) dieser Zeile aus,
 
Vielleicht könnt ihr mir helfen. Würde mich tierisch freuen.
 
LG
Antwortento top
#2
Hallöchen,

hier mal ein Ansatz. Zuerst Diene Formel, dann zwei Versionen von meiner. Du kannst in der Formel auch auf die Spaltenbezeichnungen zurückgreifen - das ist mein zweiter Ansatz. Du brauchst bei der "intelligenten" Tabelle auch keine leeren Zeilen vorhalten. Die passt sich bei einem neuen Eintrag automatisch an. Durch die Spaltennamen in den Formeln haben selbige dann auch kein Problem bei neuen Daten ...

Arbeitsblatt mit dem Namen 'Tabelle3'
ACDE
18LLG101815.09.2020133898730029
19LLG101815.09.2020133898730030
20LLG101815.09.2020133898730030

ZelleFormel
E18=INDEX($M$4:$Q$10148;VERGLEICH((MAXWENNS($Q$4:$Q$10148;$M$4:$M$10148;"*"&$A18&"*"));$Q$4:$Q$10148;0);3)
E19=SUMMENPRODUKT(($Q$4:$Q$10148=MAXWENNS($Q$4:$Q$10148;$M$4:$M$10148;"*"&$A19&"*"))*(ISTZAHL(FINDEN($A19;$M$4:$M$10148)))*$O$4:$O$10148)
E20=SUMMENPRODUKT((Tabelle5[Datum]=MAXWENNS(Tabelle5[Datum];Tabelle5[BoxID];"*"&$A20&"*"))*(ISTZAHL(FINDEN($A20;Tabelle5[BoxID])))*Tabelle5[Kunde])
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste