Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Werte innerhalb einer Zelle ermitteln
#1
Hallo,
ich habe Zellen in denen Zeichenketten wie nachfolgend dargestellet enthalten sind:

A1: 01001100
A2: 10011100
A3: 00011011

Ich möchte für jede Zelle ermitteln an welcher Stelle die erste und die letzte 1 stehen. Bei Zelle A1 sind das die Stellen 2 und 6, Bei Zelle A2 sind das die Stellen 1 und 6

Gibt es eine Möglichkeit diese Stellen zu ermitteln?

LG
Stuart
Antwortento top
#2
Hallo,

die gezeigten Werte sehen aus wie Binär-Zahlen. Excel kann sie direkt in Dezimal umrechen. Danach kann dann auf ">127", "ungerade" usw geprüft werden.

mfg

(es geht auch direkt mit VBA.Instr(1, cells(1,1), "1"))
[-] Folgende(r) 1 Benutzer sagt Danke an Fennek für diesen Beitrag:
  • sdraxler
Antwortento top
#3
Die Zahlen sehen aus wie Binärzahlen. Die Zeichenkette zeigt eigentlich Monate an. Jede Stelle steht für 1 monat. D.h. wenn an zweiter Stelle eine 1 steht, dann gab es im zweiten Monat eine Bestellung. Das nur zum Hintergrund.

Gibt es auch eine Lösung ohne VBA?
Antwortento top
#4
Code:
=FIND(1;A1;1)
und
Zitat:=FIND("@";SUBSTITUTE(A1;"1";"@";LEN(A1)-LEN(SUBSTITUTE(A1;"1";"")));1)

https://trumpexcel.com/find-characters-last-position/
Antwortento top
#5
Moin


Code:
=AGGREGAT(15;6;1/(1/(TEIL(A1;SEQUENZ(LÄNGE(A1));1)*SEQUENZ(LÄNGE(A1))));1)
=AGGREGAT(14;6;1/(1/(TEIL(A1;SEQUENZ(LÄNGE(A1));1)*SEQUENZ(LÄNGE(A1))));1)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#6
=VERGLEICH(1;--TEIL(A1;ZEILE($1:$8);1);)
=VERGLEICH(1;--TEIL(A1;ZEILE($1:$8);1))

für ältere Excel (dann wohl mit {} abzuschließen)
Antwortento top
#7
Danke. Funktioniert super!!!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste