Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Werte Zelle trennen wenn nicht vorhandene Werte kein Trennzeichen haben
#1
Folgendes Problem: ich möchte eine Werteliste wie bei 'Text in Spalten' über verschiedene Spalten aufteilen. Trennzeichen sind vorhanden, aber nicht vorhandene Werte sind nicht in Trennzeichen eingeschlossen. 
Ein Beispiel: ein Autoverkäufer führt eine Liste, über die Farben der Autos die er täglich verkauft. Wie häufig am Tag spielt keine Rolle. Das sieht dann so aus:

Tag;Farben
01.01.2020;blau
02.01.2020;blau,grün
03.01.2020;grün
04.01.2020;blau,grün,rot
05.01.2020:rot
06.01.2020:grün,rot

Die Reihenfolge der Farben ist immer identisch - aber nicht vorhandene Werte stehen eben nicht in Trennzeichen. Wie kann ich das am einfachsten in Spalten aufteilen, so dass die Farben untereinander in Spalten stehen?
Antwortento top
#2
Hi

eine Möglichkeit
Code:
____|_____A____|______B______|C|__D_|__E_|_F_|G|H|
   1|Tag       |Farben       | |blau|grün|rot| | |
   2|01.01.2020|blau         | |blau|    |   | | |
   3|02.01.2020|blau,grün    | |blau|grün|   | | |
   4|03.01.2020|grün         | |    |grün|   | | |
   5|04.01.2020|blau,grün,rot| |blau|grün|rot| | |
   6|05.01.2020|rot          | |    |    |rot| | |
   7|06.01.2020|grün,rot     | |    |grün|rot| | |
D2    =WENN(ISTFEHLER(SUCHEN(D$1;$B2));"";D$1)  nach rechts und unten ziehen

Gruß Elex
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • agentfox
Antwortento top
#3
Hallo,

ohne die erste Anwort berücksichtigt zu haben:

Zuerst fehlende Trennzeichen einfügen, also

Code:
replace(";rot", ":,,rot"
replace(":grün", ":,grün")

mfg
Antwortento top
#4
Super, die Lösung von Elex ist es  19
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste