Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wertausgabe mit Index auf ganze Tabelle
#1
Hallo Miteinander


Ich habe ein kleines Problem mit der Index Formel.


Was ich möchte:

Auswahl Typ 1.1, 1.2 und dann auch 2.1 etc.

Auswahl Geländerteil z.B Staketen

Die Wertausgaben FLA 100x10


Das funktionier auch. Möchte aber weiter unten die Typen 2.1, 2.2 ausflisten und da auch den Wert ausgeben

Wie komme ich jetzt nach da unten?

Was funktioniert ist 1.1 1.2 1.9 etc.


Formel die ich verwende:


=INDEX(A:K;VERGLEICH(N6;B:B;0);VERGLEICH(O4;2:2;0))


Ich müsste bei 2:2 irgendetwas machen, das Excel auf der ganzen Tabelle sucht. Habe diverses probiert aber komme nicht auf die Lösung. Die Tabelle geht dann mit den Typen weiter. Ich könnte die Tabelle auch anderst darstellen, ist dann aber unübersichtlich und endlos lang.



Besten Dank


Gruss


Angehängte Dateien
.xlsx   Tabelle Geländer.xlsx (Größe: 14,61 KB / Downloads: 6)
Antwortento top
#2
Moin

Anstatt nach einer Formel für diese Struktur zu suchen könnte man auch einfach die Daten in eine Datensatzliste bringen. Dann ist Lösung gleich viel einfacher.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Ja das weiss ich. Möchte dies aber so darstellen. Da es übersichtlicher ist.

Gruss MM
Antwortento top
#4
(16.02.2020, 11:04)Magicmint schrieb: Möchte dies aber so darstellen. Da es übersichtlicher ist.
Natürlich.
Arbeitsblatt mit dem Namen 'Formel vertikal_horizontal'
NOPQRSTUVWXYZ
2Typ2212,1000000
31
4Typ2,1Typ2
5GeländerteilFormel
6Staketen#BEZUG!#BEZUG!Typ 22,1Gurtes
7GeländerteilDimension
8PfostenFLA 40x12
9PfostenkröpfungKurt
10Original#BEZUG!BefestigungsplatteFLA 100x10
11UntergurtFLA 40x8
12Traverse Seilekrake
13ObergurtFLA 40x8
14HandlaufKurt
15Handlaufschale-
16StaketenGurtes
17Rahmenteil vertikal-
18Füllung / Glas-
19Glashalter-
20Fussleiste /Stirnbleche-
21Glasdichtung-
220-

ZelleFormel
S2=VERGLEICH(O2;C:C;0)
T2=INDEX(E:K;S2;0)
S3=VERGLEICH(O4;T2#;0)
S4=QUOTIENT(S2;19)+1
S6=INDEX(B:B;S2):INDEX(B:B;S2+(16))
T6=INDEX(E:K;S2;S3):INDEX(E:K;S2+(16);S3)
V6=INDEX(T6#;VERGLEICH(N6;S6#;0))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Hallo,

so würde das gehen:

Tabelle1

ABCDEFGH
1Typ 11,11,21,92,1
2PfostenFLA 40x12FLA 40x12FLA 40x12FLA 40x122,1
3PfostenkröpfungKurtFLA 40x12FLA 40x12KurtStaketenGurtes
4BefestigungsplatteFLA 100x10FLA 100x10FLA 100x10FLA 100x10
5UntergurtFLA 40x8FLA 40x8FLA 40x8FLA 40x8
6Traverse Seile---krake
7ObergurtFLA 40x8FLA 40x8FLA 40x8FLA 40x8
8Handlauf-CNS Ø42.4x2CNS Ø42.4x2Kurt
9Handlaufschale----
10StaketenFLA 100x10KurtWalterGurtes
11Rahmenteil vertikal----
12Füllung / Glas----
13Glashalter----
14Fussleiste /Stirnbleche----
15Glasdichtung----
16----
Formeln der Tabelle
ZelleFormel
H3=INDEX(B2:E16;VERGLEICH(G3;A2:A15;0);VERGLEICH(H2;B1:E1;0))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#6
Hab jetzt was Einfaches gemacht.

Mit zwei Suchkriterien und jeweils eine 1 oder 2 davorgesetzt. So geht es auch und die Formel wird nicht zu lang.


Gruss MM


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#7
Hallo,

wem nicht zu raten ist, dem ist nicht zu helfen.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste