Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wert durch Anzahl Zeilen dividieren
#1
Hallo,

once again me.

Ich möchte gerne, dass Excel mir einen prozentualen Wert ausgibt, wenn eine Zeile mit "Ja" ausgefüllt ist.
Der Prozentuale Wert soll sich dabei darauf beziehen, wie oft "ja" hätte vorkommen können.

Beispielsweise kann in den Zellen A10 bis A38; A50 bis A75 und A100 bis A128 der Wert "Ja" auftauchen.
 
Ich dachte da an sowas =ZÄHLENWENN(A10:A128;"ja")/ANZAHL(A10:A52;A56:A89;A94:A128)

Leider ergibt das die Fehlermeldung #DIV/0!

MfG
Matze
Antwortento top
#2
Hallo Matze,

ANZAHL gibt die Anzahl der Zellen zurück, die eine Zahl enthalten. "Ja" ist naturgemäß keine Zahl, ergo ergibt der Wert unterhalb des Bruchstrichs immer Null. Division durch Null muss denke ich nicht näher erläutert werden.

Versuch mal

Code:
=ZÄHLENWENN(A10:A128;"ja")/((ZEILE(A38)-ZEILE(A10)+1)+(ZEILE(A89)-ZEILE(A56)+1)+(ZEILE(A128)-ZEILE(A94)+1))

Allerdings ist das natürlich nicht besonders variabel einsetzbar - genausogut könntest du dir die Anzahl der Zellen händisch ausrechnen und als Divisor diesen Wert angeben. Denn es gibt - zumindest anhand deiner bisherigen Erklärung - keine Logik, nach der Excel erkennen kann, welche Bereiche ein "ja" enthalten könnten.
Schöne Grüße
Berni
[-] Folgende(r) 1 Benutzer sagt Danke an MisterBurns für diesen Beitrag:
  • MatthiaS04
Antwortento top
#3
Hey Matze 

mit =Anzahl ermittelst du nur wie viele Zellen eine ZAHL enthalten. 
Damit ist klar, warum die Fehlermeldung kommt.

Code:
=ZÄHLENWENNS(A1:A52;"ja")/(ANZAHLLEEREZELLEN(A1:A52)+ANZAHL2(A1:A52))

Mit dem Code solltest du auf die Lösung zu deinem Problem kommen.

mfg Gimpi
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste