Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wert ausrechnen von anderem Tabellenblatt
#1
Hallo, muss gleich sagen, dass ich bin ein Neuling in Sachen Exel bin. Hoffe dass Ihr mir helfen könnt.

Würde eine Formel brauchen, in der folgendes gerechnet wird.
1. Wenn im Feld "Leistung" -->Beschaffung steht und
2. Land Abs "D" steht und
3. Land Empf "D" steht dann
4. nimm den Wert von Verkettung aus anderem Tabellenblatt und
5. multipliziere den Wert von Verkettung mit Gewicht

Hoffe dass es verständlich ist.. Dies wäre mein Ansatz gewesen, aber funktioniert nicht

=SVERWEIS(WENN(BW3=“Beschaffung“;G3="D";L3="D");(BF3;'Beschaff DE-->DE'!$B$26:$C$125);2;0)*BG3

Danke Euch


Angehängte Dateien
.docx   Verkettung anderes Tabellenblatt.docx (Größe: 22,53 KB / Downloads: 4)
Antwortento top
#2
Hola,

ein Bild einer Exceldatei in einem Word Dokument. Pfiffig. Aber nicht hilfreich.

Zitat:nimm den Wert von Verkettung aus anderem Tabellenblatt und
Welchen genau? Da gibt es bestimmt mehrere die zu unterschiedlichen Bedingungen herangezogen werden sollen.

Lade eine aussagekräftige Exceldatei hoch als xlsx.

Gruß,
steve1da
Antwortento top
#3
Peinlich 33 33

Habe jetzt mal eine neue Exel erstellt mit anderen Zahlen...

Wichtig wäre, wenn das Gewicht bei Kategorie (min.+ max. Kosten) ist, dann muss dieser Wert übernommen werden und soll nicht multipliziert werden.

Hoffe ich habe jetzt alles richtig gemacht


Angehängte Dateien
.xlsx   Formel Verkettung.xlsx (Größe: 12,93 KB / Downloads: 4)
Antwortento top
#4
Hi,
versuche mal diese Formel:
=WENN(UND(E2="Beschaffung";A2="D";B2="D");SVERWEIS(BF3;Verkettung!C17:D66;2;0)*D2;"")
Antwortento top
#5
Moin

Ich habe es dann mal extra kompliziert gemacht.


Angehängte Dateien
.xlsx   clever-excel-forum_29160.xlsx (Größe: 17,06 KB / Downloads: 10)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#6
Mit dieser Formel sind drei Ergebnisse richtig und zwei Ergebnisse falsch. Hat was mit min. Festpreis und Max Festpreis zu tun...

Wo liegt der Fehler? siehe Anhang

=WENN(UND(E2="Beschaffung";A2="D";B2="D");SVERWEIS(C2;Verkettung!C17:D66;2;0)*D2;"")

@shift-del
mit deiner Formel bin ich nicht klar gekommen

@[b]Rabe[/b]
deine Formel hat anscheinend noch einen kleinen Fehler

Danke Euch


Angehängte Dateien
.xlsx   Formel Verkettung.xlsx (Größe: 13,44 KB / Downloads: 3)
Antwortento top
#7
Hi,

dann teste mal diese Formel:
=WENN(UND([@Leistung]="Beschaffung";[@[Land Abs]]="D";[@[Land Empf]]="D");WENN(ODER([@Gewichtsrubrik]=1;[@Gewichtsrubrik]=5);SVERWEIS([@Verkettung];Verkettung!C17:D66;2;0);SVERWEIS([@Verkettung];Verkettung!C17:D66;2;0)*D2);"N.A.")

mMn müßte es passen.

Arbeitsblatt mit dem Namen 'Kontrolle'
ABCDEFGHIJK
1Land AbsLand EmpfVerkettungGewicht in kgLeistungPLZ 1 stelligGewichtsrubrikshift_delRabe altRabe neurichtiger Wert sollte sein
2DDDE8-150Beschaffung81900,00900,0018,00
3DDDE9-2190Beschaffung9239,9039,9039,90
4HDDE7-3280Beschaffung730,00N.A.N.A.
5HDDE1-4400Beschaffung140,00N.A.N.A.
6ADDE6-5700Beschaffung650,00N.A.N.A.
7DDDE8-150Beschaffung81900,00900,0018,0018
8DDDE9-2300Beschaffung9263,0063,0063,0063
9DDDE7-3280Beschaffung7353,2053,2053,2053,2
10DDDE1-4400Beschaffung1452,0052,0052,0052
11DDDE6-5700Beschaffung6549.000,0049.000,0070,0070

ZelleFormel
C2=VERKETTEN("DE";[@[PLZ 1 stellig]];"-";[@Gewichtsrubrik])
H2=UND([@Leistung]="Beschaffung";[@[Land Abs]]="D";[@[Land Empf]]="D")*FILTER(tbl_Werte[Wert];(tbl_Werte[PLZ-Region]=[@[PLZ 1 stellig]])*(tbl_Werte[Gewichtsrubrik]=[@Gewichtsrubrik]))*D2
I2=WENN(UND([@Leistung]="Beschaffung";[@[Land Abs]]="D";[@[Land Empf]]="D");SVERWEIS([@Verkettung];Verkettung!C17:D66;2;0)*D2;"N.A.")
J2=WENN(UND([@Leistung]="Beschaffung";[@[Land Abs]]="D";[@[Land Empf]]="D");WENN(ODER([@Gewichtsrubrik]=1;[@Gewichtsrubrik]=5);SVERWEIS([@Verkettung];Verkettung!C17:D66;2;0);SVERWEIS([@Verkettung];Verkettung!C17:D66;2;0)*D2);"N.A.")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


.xlsx   Versandkosten Rabe.xlsx (Größe: 20,33 KB / Downloads: 0)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste