Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

"Wenn" und "Summen"-Funktion
#1
Hallo zusammen,

ich hab jetzt schon ein wenig herumprobiert, bekomme es aber einfach nicht hin:

Die Spalten setzten sich aus Quartalen zusammen und die Zeilen aus Kennzahlen. Für die weitere Auswertung will ich nun ein Portfolio erstellen, in dem bestimmte Kurse landen. Ein Portfolio besteht aus der Attribut "Hoch" und >6.
Also z.B. wenn in C79 "HOCH" steht und in C78 der Wert >6 ist, dann soll der Wert in C53 genommen und mit den anderen addiert werden.
Ich habe ja ganz viele Unternehmen untereinander. Letztendlich sollen in einem Feld alle Werte des Quartals addiert werden, die "HOCH" und >6 sind.

Mit welchen Funktionen und Verschachtelungen geht das am besten? 
Ich hab Schwierigkeiten die beiden Kriterien miteinander zu verbinden und dann eine Summe aus allen Unternehmen zu bilden.
Wäre super, wenn sich da jemand auskennt. Danke!Smile

Tabelle:    
Antwortento top
#2
Hola,

Schau dir mal Summewenns() an. 

Gruß,
steve1da
Antwortento top
#3
Hey,
danke für die Antwort.

=SUMMEWENNS(C53:C53;C79:C79;"HOCH";C78:C78;7)
Hat jetzt erstmal soweit Funktioniert. 
Zwei Fragen ergeben sich jetzt daraus:

- Wie schreib ich "Größer als 6" in die Funktion. Da kam immer nur ein Fehler :/ Deswegen steht da jetzt "7" zum testen...

- Und wie bekomm ich die Funktion auf alle Unternehmen übertragen, sodass ich letztendlich nur eine Summe aus allen Werten bekomme?
Antwortento top
#4
Hola,

...;">6"....
Wenn du alle Unternehmen abdecken möchtest, musst du die Bereiche in der Formel entsprechend erweitern. Aktuell fragst du ja nur eine Zelle ab. 

Gruß,
steve1da
Antwortento top
#5
Hey, danke für die HilfeSmile

Ja, ich hab das jetzt erstmal nur an einem Unternehmen getestet.

Ich verstehe aber noch nicht ganz, wie ich den Bereich erweitere. Insgesamt sind es ja 100 Unternehmen mit jeweils 21 Kennzahlen.
Von diesen 21 Kennzahlen, sind für mich ja nur die 3 Werte "Kurs", "Hoch" und ">6" relevant.

Wenn ich den Wertebereich auf die ganze Spalte lege kann ich doch gar nicht festlegen, dass nur jeweils die Zeile mit dem "Kurs" addiert werden soll?
Das versteh ich noch nicht so ganz, wie ich den Wertebereich denn erweitere auf die 100 Unternehmen bzw. nur auf die Zeile mit dem Kurs fixiere.

Ich will ja am Ende nur eine Zelle haben, wo alle Kurse addiert sind, die die Kritierien "Hoch" und ">6" erfüllen.

Danke dir schonmal für die Geduld

Gruß
Antwortento top
#6
Dann lade bitte eine Excel Datei hoch und trage dort händisch dein Wunschergebnis ein. 

Gruß,
steve1da
Antwortento top
#7
Hallo Ardente,

hier mal ein Lösungsversuch, der die Anzahl der erfüllten Bedingungen aufsummiert.
Testweise für in diesem Besipiel 2 Unternehmen mit jeweils 31 Datensätze (=31 Zeilen) ab Zeile 51ff.
Beispielsweise in Zelle "C45":
Code:
{=MIN(SUMME(($B$51:$B$112="F-Score")*(C$51:C$112>=6)*((GANZZAHL((ZEILE(51:112)-51)/31)+1)=(GANZZAHL((ZEILE(51:112)-51)/31)+1))*1);SUMME(($B$51:$B$112="BOOK TO MARKET RATIO HOCH/NIEDRIG")*(C$51:C$112="HOCH")*((GANZZAHL((ZEILE(51:112)-51)/31)+1)=(GANZZAHL((ZEILE(51:112)-51)/31)+1))*1))}

mit STRG+UMSCHALT+EINGABETASTE abschließen, um diese Matrixformel zu erstellen.

Gruß Remarque
Antwortento top
#8
Hallo zusammen,

ich habe mal eine etwas gekürzte Excelversion angefügt.

@Remarque66: Danke für den Vorschlag, allerdings zeigt mit die Zelle nur die Anzahl der Betreffenden Unternehmen an. Es sollen in Zelle aber die Kurse addiert dargestellt werden.

In der Datei die ich hochgeladen habe, sind 3 Unternehmen. Zwei davon erfüllen die Kriterien "Hoch" und ">6". Jetzt sollen in einer Zelle von den beiden Unternehmen der Aktienkurs summiert dargestellt werden. Sprich es müsste 4,19 + 24,298 = 29,175 in der Zelle stehen.

Ist das irgendwie über eine Formel möglich?


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 12,39 KB / Downloads: 5)
Antwortento top
#9
Hallöchen,

im Prinzip für eine Bedingung so:

=SUMMEWENN(C13:C333;"HOCH";C3:C323)

SUMMEWENNS verarbeitet dann auch mehrere Bedingungen
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste