Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn in Spalte A1 Bestimmtes Wort
#1
Hi,

ich suche eine Formel die mir in die Zeile C1 den Wert aus A1 kopiert, wenn in B1 ein bestimmtes Wort steht.

Fall 1
A1 = 100
B1 = 
C1 = 

Fall 2
A1=100
B1=drin
C1=100

Hoffe es war verständlich.

LG und Danke im Voraus
Antwortento top
#2
Hallo,

=WENN(A2="drin";A1;"")

Gruß Werner
Antwortento top
#3
Hi,

leider kommt da als Wert nur #Wert.
Antwortento top
#4
Hallo, das kann ich zwar nicht nachvollziehen mit #WERT! Aber versuch mal..:

PHP-Code:
=WENN(ISTTEXT(B1);A1;""


Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
1100drin100100

ZelleFormel
C1=WENN(ISTTEXT(B1);A1;"")
D1=WENN(B1="drin";A1;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
1100

ZelleFormel
C1=WENN(ISTTEXT(B1);A1;"")
D1=WENN(B1="drin";A1;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#5
Ich gehe über zwei Tabellen, liegt es daran?
Hier meine Formel:

Code:
=WENN('Tabelle1'!O19:P20="drin";'Tabelle1'!S19:T20;"")


LG und Danke
Antwortento top
#6
Nö, es liegt an den Bereichen... in meiner Excel-Version geht das aber..:

Arbeitsblatt mit dem Namen 'Tabelle1'
OPQRST
19drin10025
20drin30
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Arbeitsblatt mit dem Namen 'Tabelle3'
CD
4100
50

ZelleFormel
C4=WENN(Tabelle1!O19:P20="drin";Tabelle1!S19:T20;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Du musst so tun..:

Arbeitsblatt mit dem Namen 'Tabelle3'
CD
8100
90

ZelleFormel
C8=WENN(Tabelle1!O19="drin";Tabelle1!S19;"")
D8=WENN(Tabelle1!P19="drin";Tabelle1!T19;"")
C9=WENN(Tabelle1!O20="drin";Tabelle1!S20;"")
D9=WENN(Tabelle1!P20="drin";Tabelle1!T20;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#7
Hallo,


Zitat:Ich gehe über zwei Tabellen, liegt es daran?

=WENN('Tabelle1'!O19:P20="drin";'Tabelle1'!S19:T20;"")

Vielleicht erleuchtet mich ja jemand

was Formeln angeht, hat mich die Muse ganz sicher nicht geküßt,
aber wie ich das sehe, ist da nichts von zwei Tabellen zu sehen

Vielleicht erleuchtet mich ja jemand
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

Grüße aus Norderstedt, Peter
Antwortento top
#8
Hi Peter, wenn die Werte in einer anderen Tabelle (Tabellenblatt) vertreut sind, kann das Einiges erklären..?! Die Formel zum Beispiel steht in Tabelle3... Aber der eigentliche Grund hier, dass der TE Bereiche angibt, das geht noch nicht so furchtbar lange, villeicht als Matrixformel... in Excel 365 braucht's das nicht mehr...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Käpt'n Blaubär
Antwortento top
#9
Hallo Jörg,

ähm ja, dann wird das ja noch schlüpfriger für mich.
Ich habe gerade beschlossen, ich bleibe doch lieber bei VBA, da kenne ich mich wenigstens aus.

Weil das Alles so undurchsichtig ist, habe ich glatt das Wichtigste vergessen. Danke Jörg, für die Info
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

Grüße aus Norderstedt, Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Käpt'n Blaubär für diesen Beitrag:
  • Jockel
Antwortento top
#10
Hallo zusammen,

jetzt funktionieret es.
@Jockel: dein letzter Post hat gepasst, DANKE.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste