Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn dann-Funktion mit Formeln
#1
Guten Tag,

Ich habe ein Problem beim erstellen einer Tabelle und hoffe, dass Ihr mir helfen könnt. Blush 

Ich möchte eine Tabelle erstellen in der, je nach eingetragenem Wert, zwar immer mit der Gleichen Formel gerechnet wird aber Werte aus anderen Feldern berücksichtigt werden.
Als Beispiel:
Ist der Wert in Feld A1 kleiner/Gleich 4 rechne mit A2 * A1
Ist der Wert in Feld A1 kleiner/Gleich 12 Rechne mit A3 * A1
und Ist der Wert größer 12 dann rechne mit A4 * A1.

Ist das bei Excel möglich?

Vielen Dank schonmal im voraus.
19
Antwortento top
#2
Hallo,

natürlich.

=WENN(A1<=4;A2*A1;WENN(A1<=12;A3*A1;A4*A1))
Cadmus
Antwortento top
#3
Hi,

Arbeitsblatt mit dem Namen 'Tabelle2'
AB
15Ergebnis:
2225
35
46

ZelleFormel
B2=WENN($A$1<=4;A2*$A$1;WENN($A$1<=12;A3*$A$1;A4*$A$1))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#4
Moin

Vielleicht auch so:
Code:
=A1*VERWEIS(A1;{0;5;13};$A$2:$A$4)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • Jockel
Antwortento top
#5
Hallo, oder..:

PHP-Code:
=A1*INDEX(A:A;VERGLEICH(A1;{0.5.13};1)+1
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste