Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn Zelleninhalt zu lang - letztes Wort entfernen
#1
Question 
Hallo zusammen,

ich habe folgendes Problem:

Der Inhalt einer Zelle soll sich aus der Verkettung mehrerer anderer Zellen zusammensetzen. Jedoch darf dann die Zeichenlänge in der Zelle 50 nicht übersteigen. Wenn es mehr als 50 Zeichen in der verketteten Zelle sind, soll in einer anderen Spalte der Inhalt ohne das letzte Wort (oder die letzten Wörter), das zur Zeichenüberschreitung von 50 geführt hat, entfernt werden. Da die Wörter mit Komma getrennt werden, soll auch noch das letzte Komma mit entfernt werden.

Damit es hoffentlich etwas klarer wird, habe ich eine Beispieldatei angehängt.

Es wäre super, wenn hier jemand einen Lösungsvorschlag hätte.

Ich danke vielmals im Voraus!

Viele Grüße
Xophia


Angehängte Dateien
.xlsx   Wenn Titel zu lang - Wort entfernen.xlsx (Größe: 10,43 KB / Downloads: 7)
Antwortento top
#2
Vielleicht hilft ein Blick in Herbers Zauberkiste:

Einen langen Text einer Zelle auf vorgegebene Zeichenzahl
Antwortento top
#3
C2: =WECHSELN(LINKS(A2;MAX(WENN((TEIL(A2&" ";ZEILE($1:$299);1)=" ")*(ZEILE($1:$299)<51);ZEILE($1:$299))))&"  ";",  ";)

B2 überflüssig
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • Xophia
Antwortento top
#4
Hallo LCohen,

super - es funktioniert prima! Vielen Dank dafür!
Antwortento top
#5
Meine Formel ist zwar viel länger, funktioniert aber auch.

=WENN(LÄNGE(A2)<51;A2;TEIL(A2;1;FINDEN("#";WECHSELN(TEIL(A2;1;50)&WECHSELN(TEIL(A2;51;999);", ";"@@");",";"#";LÄNGE(A2)-LÄNGE(WECHSELN(TEIL(A2;1;50)&WECHSELN(TEIL(A2;51;999);", ";"@@");",";""))))-1))
VG, wisch
Wer Hilfe nimmt, sollte auch Hilfe geben! Auch wenn dies auf einem ganz anderm Gebiet geschieht.
[-] Folgende(r) 1 Benutzer sagt Danke an wisch für diesen Beitrag:
  • Xophia
Antwortento top
#6
Oder die.
=WENN(LÄNGE(A2)<51;A2;LINKS(A2;VERWEIS(999;FINDEN(",";LINKS(A2;51);SPALTE(1:1)))-1))
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • Xophia
Antwortento top
#7
wisch und Elex - euch auch vielen Dank! Eure Formeln funktionieren auch super!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste