Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn-Funktion von bis
#1
Hallo! Leider komme ich mal wieder an meine Grenzen. Ich möchte folgendes darstellen:

65-100% soll ein "Win" in der Zelle erscheinen
40-64,99% ein "Draw"
alles unter 40% "Lose"

Das habe ich bisher gebastelt, aber irgendwo liegt ein Fehler und ich komme leider nicht drauf:

=WENN(A23>60,01%;"Win";(und(A23>=60%;A23<=40%);"Draw");A23<=39,9%;"Lose")

Vielen Dank vorab für die Hilfe. 

Grüße,
franke80
Antwortento top
#2
Hola,

na da fehlen 2x WENN in deiner Formel. Jede Abfrage von Bedingungen muss mit WENN starten.
Geht aber auch so:

Code:
=WENN(A23>60,01%;"Win";WENN(UND(A23>=60%;A23<=40%);"Draw";"Lose"))

Gruß,
steve1da
Antwortento top
#3
(21.09.2020, 14:14)steve1da schrieb: Hola,

na da fehlen 2x WENN in deiner Formel. Jede Abfrage von Bedingungen muss mit WENN starten.
Geht aber auch so:

Code:
=WENN(A23>60,01%;"Win";WENN(UND(A23>=60%;A23<=40%);"Draw";"Lose"))

Gruß,
steve1da

Sorry aber das funktioniert nicht. Alles unter 60% gibt er mir als "Lose" aus.
Antwortento top
#4
Hola,

sorry, mein Fehler. Ich hab deine Logik-Fehler mit übernommen.
Du musst im mittleren Teil die 40 und 60 vertauschen. Gbit halt keine Zahl die gleichzeitig größer als 60 und kleiner als 40 ist.

Gruß,
steve1da
Antwortento top
#5
Hallo,

zu:
Zitat:Du musst im mittleren Teil die 40 und 60 vertauschen.

Die Überprüfung "A23<=60" ist nicht notwendig, da er durch die äussere Wenn-Bedingung in diesen Zweig nur kommt wenn A23 kleine oder gleich 60 ist.
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste