Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn Funktion
#1
Hallo liebe Forum Mitglieder,

ich scheitere an einer verschachtelten "WENN" Funktion!

Ich habe in der Zelle C3 einen Umsatz der in Abhängigkeit des Betrages mit Prozenten multipliziert werden soll!

=WENN(C3>500;C3*0,18;C3*0,15)

mit 15 und 18 Prozent mit Werten unter 500 und über 500 bekomme ich das hin.

Das Problem:
ab 1       = 15%
ab 500   = 18%
ab 1000 = 21%
ab 1500 = 24%
ab 3000 = 26%

Kann mir jemand helfen?
Antwortento top
#2
Hola,

=wenn(C3>5000;C3*0,26;wenn(C3>1500;C3*0,24;........))

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • MScholz
Antwortento top
#3
Hallo M...,

schreibe die Grenzen und Prozentzahlen in eine Liste und nutze die Funktion SVERWEIS (in neuerem Excel besser XVERWEIS).


= C3*SVERWEIS(C3;.....)
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





[-] Folgende(r) 1 Benutzer sagt Danke an Ego für diesen Beitrag:
  • MScholz
Antwortento top
#4
Dachte ich mir das SVerweis die Lösung ist!

Ich brauchte ja auch nur auf die Prozente verweisen diese anzuzeigen und dann multiplizieren!
So beim Forum dursuchen kommen einen die guten Ideen! Undecided
Antwortento top
#5
Hi,

oder so:

Code:
=VERWEIS(C3;{1;500;1000;1500;3000};{15;18;21;24;26})%*C3
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste