Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn/Dann formel überprüfung text
#1
Hallo Zusammen,

wie schreibe ich folgende Formel in Excel richtig.

1. Wenn in Zelle A1 das wort "Zelle" eingetragen wird dann bitte in B1 folgendes Zeichen schreiben "%"

zweite frage
In der Bsp. Tabelle stehen diverse werte mit verschieden texten. 
ich möchte jetzt das Excel die Summen bildet entsprechend den Texten in C
Die Formel soll auch die zukünftigen Eintragungen automatisch dazu addieren, so das man nicht jedes mal Manuel neue werte dazu addieren muss.


Vielen Dank


Angehängte Dateien
.xlsx   Bsp.xlsx (Größe: 12,65 KB / Downloads: 7)
Antwortento top
#2
Hola,

=wenn(A1="zelle";"%";"")

Frage 2: schau dir Summewenn() an.

Gruß,
steve1da
Antwortento top
#3
Moin,

Zu 1:
Code:
=WENN(A1="Zelle";"%";"irgendwas oder nix")
Diese Formel in B1

Zu 2:
Arbeitsblatt mit dem Namen 'Tabelle1'
DE
1Text13
2Text24
3Text33

ZelleFormel
E1=ZÄHLENWENN($C$8:$C$17;D1)
E2=ZÄHLENWENN($C$8:$C$17;D2)
E3=ZÄHLENWENN($C$8:$C$17;D3)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#4
Hallo Willi,

ich möchte das die werte welche in Spalte D stehen zusammen addiert werden.
Antwortento top
#5
Hi,

das hatte ich missverstanden.

Dann so (Steve hat dir ja bereits geschrieben, dass das Zauberwort SUMMEWENN() heißt):
Arbeitsblatt mit dem Namen 'Tabelle1'
DE
1Text1201,55
2Text20
3Text30

ZelleFormel
E1=SUMMEWENN($C$8:$C$17;D1;$D$8:$D$17)
E2=SUMMEWENN($C$8:$C$17;D2;$D$8:$D$17)
E3=SUMMEWENN($C$8:$C$17;D3;$D$8:$D$17)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Die Suchtexte müssen identisch mit den Texten in Spalte C sein.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
(17.04.2020, 11:31)Pirat2015 schrieb: Hallo Willi,

ich möchte das die werte welche in Spalte D stehen zusammen addiert werden.
anhand deiner tabelle dann
=SUMMEWENN(C:C;"Text1";D:D)
oder
=SUMMEWENN(C:C;"Text2";D:D) usw
Antwortento top
#7
Hallo trustssc,

ich würde nicht ganze Spalten beackern.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
(17.04.2020, 11:42)WillWissen schrieb: Hallo trustssc,

ich würde nicht ganze Spalten beackern.
ist doch egal so kann er die tabelle ewig weiterführen denn sobald er aus dem bereich wäre wenn man einen zuweist macht er keine summe mehr
Aber so wie die Tabelle vom ersteller aussieht soll das wohl so eine Art Haushaltsbuch werden
da Müsste er die formel dann sowieso für die einnahmen und ausgaben machen
Antwortento top
#9
Hi,


Zitat:ist doch egal[...]

du hattest wohl noch nie Performanceprobleme? Übrigens kannst du ja den zu überprüfenden Bereich relativ großzügig angeben; damit kommst du auch nicht in die Bredouille, Formeln ergänzen zu müssen. Oder du arbeitest mit einer intelligenten Tabelle, oder mit benamten Bereichen...
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#10
Wie auch immer ich kenne keine Performanceprobleme aber ist ja auch egal viele wege füren nach Rom

wenn er es als tabelle formatiert kann er sich ja auf die spalte beziehen oder gibt halt nen bereich ein der größer ist
=SUMMEWENN(C8:C5000;"text1";D8:D5000) für die einnahmen

=SUMMEWENN(C8:C5000;"text1";E8:E5000) für die Ausgaben

der Ersteller kann mich auch anschreiben dann mach ich im ne Tabelle wo sich das auf die @Spalte bezieht aber denke mal das bekommt er hin
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste