Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

WENN mehrere Anweisungen
#1
Hey,
ist es möglich einer WENN Funktion mehrere Anweisungen zu geben wenn der Wert Wahr ist?
Antwortento top
#2
Hallo,

geht's vllt. etwas genauer bitte?
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Man kann ja 2 Anweisungen geben eine wenn der Wahrheitstest wahr ist und eine wenn er falsch ist. Ich will mehere Anweisungen geben wenn er wahr ist
Antwortento top
#4
Nö, das geht nicht. Aber bring doch mal ein Beispiel, wie du dir das vorstellst. Vllt. gibt's 'ne andere Möglichkeit.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
Ich will den Text mehrerer Zellen ändern wenn ich in einer anderen Zelle den Text ändere
Edit: Hier noch ein schnelles Beispiel


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 8,49 KB / Downloads: 5)
Antwortento top
#6
Hi,

zwei Zellen mit einer Formel geht nicht, aber wäre das für dich ok?

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
1testWenn in A1 "Test" steht soll hier "Bestanden" stehenund hier soll "Sehr gut" stehen
2TestBestandenSehr gut

ZelleFormel
B2=WENN(A1="Test";"Bestanden";"sonst irgendwas oder leer")
C2=WENN(A1="Test";"Sehr gut";"sonst irgendwas oder leer")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Berdi
Antwortento top
#7
Hallöchen,

Wenn Du den Text in mehreren Zellen ändern willst dann brauchst Du in jeder Zelle ggf. das WENN oder was vergleichbares.

Oder meinst Du was in der Art? D1 und D2 müssen dabei nicht unbedingt Formeln sein, Du könntest auch direkt was eintragen. Um die Sache etwas aufzuhübschen könntest Du die Zellen D1 und D2 auch in Text1 und Text2 umbenennen und dann in Spalte A statt =D1 dann =Text1 schreiben.

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1OhOhOh
2OhAhAh
3Oh
4Oh
5Oh
6Oh
7Oh

ZelleFormel
A1=$D$1
D1=WENN(E1="";F1;E1)
A2=$D$1
D2=WENN(E2="";F2;E2)
A3=$D$1
A4=$D$1
A5=$D$1
A6=$D$1
A7=$D$1
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#8
Hi,


Zitat:Wenn Du den Text in mehreren Zellen ändern willst dann brauchst Du in jeder Zelle ggf. das WENN oder was vergleichbares.
ist mein voriger Beitrag nicht sichtbar?
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#9
Hoi,

wo ist da das Vergleichbare?
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#10
Hallo Berdi,

hier ein Lösungsvorschlag mit einer Hilfstabelle und SVERWEIS:

Arbeitsblatt mit dem Namen 'Tabelle2'
ABCDEFG
1BegriffText1Text2Hilfstabelle
2TestBestandenSehr gutBegriffText1Text2
3irgendwasabcxyzTestBestandenSehr gut
4nochwasirgendwasabcxyz
5
6
7
8

ZelleFormel
B2=WENNFEHLER(SVERWEIS($A2;$E$2:$G$11;2;0);"")
C2=WENNFEHLER(SVERWEIS($A2;$E$2:$G$11;3;0);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Gruß
Fred
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste