Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

WENN-UND Funktion mit INDEX
#1
Hallo Liebes Forum. Ich komme bei meinem Anliegen nicht weiter. Und zwar, ich habe 2 Tabellen. Die erste ist Vertikal und soll eine Einsatzplanung (Tabelle 1) eines Mitarbeiters zeigen und die zweite (Tabelle 2) Horizontal und soll die Urlaubsplanung aller Mitarbeiter zeigen. Nun möchte ich gerne, das wenn ich in Tabelle 2 in einen Tag ein "U" einschreibe das es mir das in der Einsatzplanung des Mitarbeiters im gleichen Tag als Wort "Urlaub" und nicht nur als "U" wieder gibt. Diese Formel möchte ich dann gerne in Tabelle 1 nach unten ziehen, sodass es alle "U" aus der Horizontalen Urlaubstabelle (Tabelle 2) in ein "Urlaub" in die Vertikale Tabelle 1 übernimmt. Das gleiche plane ich mit dem Buchstaben "K" als "Krank". Könnt ihr mir helfen?
Antwortento top
#2
mach bitte ein beispiel mäppchen fertig.
Antwortento top
#3
Hola,

können wir. 
Aber nur wenn du eine Exceldatei hochlädst.

Gruß,
steve1da
Antwortento top
#4
Sorry. Anbei die Datei.

Mit der WENN-UND Funktion bin ich schon soweit gekommen dass es aus dem "U" ein "Urlaub" in entsprechender Spalte einträgt, nur hängst eben am kopieren der Zeilen nach unten.

Ergänzend ist noch zu erwähnen, dass im Tabellenblatt "Urlaubsplanung" der Bezug zur Zelle A3 "Januar" hergestellt werden muss, (daher die WENN-UND Funktion) da ich diese Tabelle für alle Monate des Jahres anfertigen möchte. Das hatte ich noch vergessen mit zu erwähnen.


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 14,94 KB / Downloads: 8)
Antwortento top
#5
Hallo,

verwendet echte Datumsangaben im Tabellenblatt Urlaubsplanung und bilde das komplette Jahr in einer Zeile ab.

Die Zuordnung kann dann einfach über Wverweis erfolgen.


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 19,42 KB / Downloads: 10)
Cadmus
Antwortento top
#6
Danke für den Lösungsansatz. Aber kann ich die Wenn-Und Funktion nicht zusammen mit der Index Funktion verwenden? Sowas wie =Wenn(Und(Index . . . ?
Antwortento top
#7
Ich sehe in deiner Datei keine Wenn/Und/Index Funktion.


Zitat:...der Bezug zur Zelle A3 "Januar" hergestellt werden muss, (daher die WENN-UND Funktion)


Muss nicht, bei echten Datumswerten in der Urlaubsplanung (wie ich sie in deiner Datei ersetzt habe).

Mit

=WENN(WVERWEIS(B4;Urlaubsplanung!$B$3:$NC$20;3;0)="U";"Urlaub";WENN(WVERWEIS(B4;Urlaubsplanung!$B$3:$NC$20;3;0)="K";"Krank";""))

hast du auch "Krank" drin.
Cadmus
Antwortento top
#8
Danke dir Cadmus. Meine Formel hab ich raus gelöscht da sie nicht funktionierte. Ich hatte mich halt so auf die Wenn Und Index Funktion versteift da ich die Wenn Und Funktion schon in einer Spalte drin stehen hatte und sie nur erweitern wollte. 

Daher die Frage ob ich die Wenn Und Funktion mit dem Index erweitern kann. Ich bekomme dann immer den Fehler #Name
Antwortento top
#9
#Name

Funktion falsch geschrieben, Klammern vergessen?
Cadmus
Antwortento top
#10
Klammern hatte Excel automatisch ergänzt. Ich denke irgendwo ein Fehler in der Schreibweise. An welche Stelle muss denn der Index? Ich hatte es so geschrieben =WENN(UND(INDEX
Die WENN UND Funktion hatte ich ganz normal geschrieben und hinten dran dann den Index gehängt. Ich habe eben bei Google keine Verschachtelung mit den 3 Funktionen zusammen gefunden.

Camus, kann ich die Urlaubsmonate auch untereinander schreiben? Ich wollte ungern so weit nach rechts scrollen. Nach unten geht doch einfacher und schneller.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste