Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

WENN ODER bzw. Verschachtelte WENN Funktion
#1
Hallo allerseits,

ich suche gerade nach einem Weg, wie in einer Zelle abhängig vom Wert in der Zelle nebenan, ein vorgegebener Zahlenwert (1, 2 oder 3) erscheinen soll. 

Also konkret soll in Zelle O7 dann eine 3 angezeigt werden, wenn der Zellwert in N7 größer als 0 ist. Eine 2 soll angezeigt werden, wenn der Zellwert in N7 =0 ist und eine 1, wenn der Zellwert kleiner als 0 ist.

Geht sowas irgendwie in einer Formel ? Ich hab es schon mit WENN ODER versucht, allerdings ohne wirklichen Erfolg. 

Vielen Dank im Voraus für Eure Tipps.
Wer Schreibfehler findet, darf diese behalten.
Antworten Top
#2
Hi,

um erstmal bei WENN zu bleiben:

=WENN(N7>0;3;WENN(N7<0;1;2))
[-] Folgende(r) 1 Nutzer sagt Danke an {Boris} für diesen Beitrag:
  • Schnurbsel
Antworten Top
#3
Perfekt, vielen Dank. 17
Wer Schreibfehler findet, darf diese behalten.
Antworten Top
#4
O7: =VORZEICHEN(N7)+2
WIN/MSO schicken angeblich alle 5 Sekunden Deinen Screen heim zu Papa (recall-Klausel). 
[-] Folgende(r) 1 Nutzer sagt Danke an LCohen für diesen Beitrag:
  • Der Steuerfuzzi
Antworten Top
#5
Moin!
Wenn es "nur" um die Anzeige geht,
reicht auch das benutzerdefinierte Zahlenformat 3;1;2
AB
1-151
202
323,43

ZelleFormatWert
B13;1;2-15
B23;1;20
B33;1;223,4

ZelleFormel
B1=A1
B2=A2
B3=A3

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
[-] Folgende(r) 1 Nutzer sagt Danke an RPP63 für diesen Beitrag:
  • Der Steuerfuzzi
Antworten Top
#6
RPP63s Format als Formel: O7: =--TEXT(N7;"3;1;2")
WIN/MSO schicken angeblich alle 5 Sekunden Deinen Screen heim zu Papa (recall-Klausel). 
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste