Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Verschachtelte Wenn-Formel
#1
Bis anhin verwendete ich die Wenn-Formel um bei bei 25 Jahren= "Silberne" und bei 50 Jahren= "Goldene" auszugeben.
=WENN(ISTFEHLER(WENN(AK$1-O60=25;"Silberne";WENN(AK$1-O60=50;"Goldene";"")));"";WENN(AK$1-O60=25;"Silberne";WENN(AK$1-O60=50;"Goldene";"")))

Nun wollte ich erweitern auf 60 Jahre = "Diamantene" aber nichts geht mehr. Es gibt auch keine Fehlermeldung!

=WENN(ISTFEHLER(WENN(AK$1-O167=25;"Silberne";WENN(AK$1-O167=50;"Goldene";WENN(AK$1-O167=60;“Diamantene“;""))));"";WENN(AK$1-O167=25;"Silberne";WENN(AK$1-O167=50;"Goldene";WENN(AK$1-O167=60;“Diamantene“;""))))

In AK1 steht das heutige Jahr.

Würde mich freuen.....
Gruß heli05
Antwortento top
#2
Geht mit einem SVERWEIS viel einfacher: in Tabelle 2 die Jahreszahl in Spalte A und den dazugehörigen Text in Spalte B. Dann die Formel:

=WENNFEHLER(SVERWEIS(AK1-O60;Tabelle2!A:B;2;FALSCH);"")

Da kannst du auch noch beliebig erweitern ( Eiserne, ...) und musst die Formel nie mehr ändern.
VG, wisch
Wer Hilfe nimmt, sollte auch Hilfe geben! Auch wenn dies auf einem ganz anderm Gebiet geschieht.
[-] Folgende(r) 1 Benutzer sagt Danke an wisch für diesen Beitrag:
  • heli05
Antwortento top
#3
Hallo,

=WENNFEHLER(SVERWEIS(AK1-O60;{25."Silberne";50."Goldene";60."Diamantene"};2;0);"")
Cadmus
[-] Folgende(r) 1 Benutzer sagt Danke an Cadmus für diesen Beitrag:
  • heli05
Antwortento top
#4
(31.08.2020, 07:04)Cadmus schrieb: Hallo,

=WENNFEHLER(SVERWEIS(AK1-O60;{25."Silberne";50."Goldene";60."Diamantene"};2;0);"")
 Besten Dank dafür!!
Antwortento top
#5
PHP-Code:
=CHOOSE(INT((A1+15)/25);"siberne";"golden";"diamant"
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antwortento top
#6
Danke! Die Formel müsste in etwa so aussehen.

=CHOOSE(INT((AK$1-O2=25);"silbern";"golden";"diamant"))

golden=50 diamant=60 ??
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste