Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Vermutlich verschachtelte Wenn-Dann-Funktion?
#1
Guten Tag alle zusammen,

ich verzweifle an einer (wahrscheinlich) einfachen Sache, an der ich aber leider schon mehrere Tage sitze.

Wir führen in unserer Firma Listen über die Stunden unserer Mitarbeiter, wann wie lange, mit welchen Zuschlägen etc gearbeitet wurde. Hierzu fallen Überstunden an, welche in das Arbeitszeitkonto (AZ-Konto) gut geschrieben werden bis 150 Stunden erreicht sind. Ist dieses AZ-Konto voll und der Mitarbeiter erwirtschaftet wieder Überstunden werden die ihm direkt ausbezahlt.

Den Stand des AZ-Kontos vom Vormonat gebe ich oben händisch ein (Q2).
Excel errechnet mir die Überstunden welche in das AZ-Konto fließen in (B39).

Nun möchte ich quasi 3 Fälle in einer Zelle darstellen:

1. AZ-Konto Stand Vormonat weißt 10 Stunden auf, der Mitarbeiter hat 40 Überstunden gemacht, also bekommt er auch 40 Stunden im AZ-Konto gut geschrieben.
  Meine Formel: =WENN(Q2=150;0;B38-B37)

2. AZ-Konto Stand Vormonat weißt 150 Stunden auf, der Mitarbeiter hat 40 Überstunden gemacht, also bekommt er 0 Stunden im AZ-Konto gut geschrieben, da dieses direkt ausbezahlt werden.
  Meine Formel: =WENN(Q2=150;0;B38-B37)

3. AZ-Konto Stand Vormonat weißt 130 Stunden auf, der Mitarbeiter hat 40 Überstunden gemacht, also bekommt er 20 Stunden im AZ-Konto gut geschrieben, da ab 150 Stunden die Überstunden ausbezahlt werden.
Hier hab ich versucht in der Exceltabelle etwas zu basteln, aber ich scheine einen Denkfehler zu haben, bzw. ich bekomme es nicht hin, dass er die 150 Stunden als Maximalwert nimmt und anschließend nur die Differenz zu 150 Stunden und dem AZ-Konto vom Vormonat als Differenz AZ-Konto ausweist.


Ich hoffe ihr könnt mir helfen und ich habe mich nicht all zu kompliziert ausgedrückt.
Wünsch euch allen noch eine schöne Woche.

Liebe Grüße
Sarah


Angehängte Dateien
.xls   Test AZ-Konto.xls (Größe: 98 KB / Downloads: 7)
Antwortento top
#2
Hallo,

da reicht das:

Code:
=MIN(B38;150-Q2)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#3
(09.06.2020, 07:34)BoskoBiati schrieb: Hallo,

da reicht das:

Code:
=MIN(B38;150-Q2)

Hallo Edgar,

danke, dass du dich meinem Problem angenommen hast, leider bringt es nicht die Auswertung, die ich benötige, aber vllt kann ich deine Formel für eine andere Auswertung benötigen.

Vielen lieben Dank
LG Sarah
Antwortento top
#4
Hi,

dann verrate mir mal, was die Funktion falsch macht. Mir spuckt die Formel genau die Stunden aus, die ins AZ-Konto fließen sollen.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
Hallo Sarah,

In deiner Datei wird ja so gut wie nichts berechnet, alles zu Fuß.

Vielleicht ist hier was dabei.

Lg
Roger


Angehängte Dateien
.xls   Test AZ-Konto_V_1.xls (Größe: 107,5 KB / Downloads: 2)
Antwortento top
#6
Hallo Edgar, 

die Funktion macht folgendes falsch:

Wenn ich bei Q2-AZ-Konto Vormonat 50 Stunden eingebe, dann erscheint in deiner Formel als Ergebnis 100. Jedoch werden nur die Stunden von B38-B37 = Diff AZ-Konto auch wirklich dem AZ-Konto gut geschrieben und keine 100 Stunden, denn so viele Überstunden hatte er ja gar nicht.

LG
Sarah

Hallo Roger,

danke für deinen Lösungsansatz, aber auch hier bringt es leider nicht das gewünschte Ergebnis.

LG
Sarah
Antwortento top
#7
Hi Sarah,

dann versuche mal das:

Code:
=MIN(B38-B37;150-Q2)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#8
Hi Sarah,

wie wäre es mit dieser Formel:

=WENN(Q2+B39>150;150;Q2+B39)

wobei mir jetzt noch der Bezug fehlt, wo die auszuzahlenden Stunden erscheinen und damit berechnet werden müssen.
Gruß Rudi
Antwortento top
#9
Hallo Rudi,

die Formel sollte in B39 stehen!
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#10
Hallo Edgar.

da bin ich mir nicht sicher. 

Ich sehe es so:

Wenn die Tabelle "MA 1" heißt, ist im Folgemonat die Formel

=wenn('MA 1'!Q2+'MA 1'!B38-'MA 1'!B37>150;150;'MA 1'!Q2+'MA 1'!B38-'MA 1'!B37)
in Zelle Q2 einzutragen 
und in Tabelle "MA 1" in Zelle B39 für die Berechnung der auszuzahlenden Überstunden die Formel
=WENN(Q2-150+B38-B37>=0;Q2-150+B38-B37;0)
einzutragen 

Gruß Rudi
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste