Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Verknüpfte Daten aus externen Quellen aktualisieren
#1
Hallo liebes clever-excel-forum, 

wiedereinmal habe ich ein Problem, mit dem ich nicht weiterkomme und hoffe auf eine Rettung von Euch Blush

Hier eine kurze Beschreibung der Thematik:

Ich habe mehrere Arbeitsmappen, die als Testfallmatrizen dienen. Hier tragen die Tester also ihre Testfälle und deren momentanen Status ein. Da es sich um sehr viele Testfälle (mehrere Tausend) in einigen (ca. 15) Testfallmatrizen handelt, habe ich eine Übersichts-Arbeitsmappe erstellt, die alle Status zusammenführt. 

Nun zum eigentlich springenden Punkt: Die Übersichts-Arbeitsmappe funktioniert, allerdings nur, wenn ich gleichzeitig alle anderen verknüpften Arbeitsmappen geöffnet habe (was natürlich nicht Sinn der Sache ist). Jetzt habe ich schon festgestellt, dass ich, damit die Übersichtsarbeitsmappe die korrekten Daten ausgibt, erst die verknüpften Arbeitsmappen schließen muss, bevor ich speichere. Allerdings aktualisieren sich die Daten in der Übersichtsarbeitsmappe nicht automatisch, sondern ich werde bei Öffnen gefragt, ob ich die verknüpften Daten aktualisieren möchte. Tue ich dies, erscheint in vielen (komischerweise nicht allen) Feldern ein #WERT!-Fehler. 

Die Formeln also solches sind nicht übermäßig kompliziert: 

Diese Formel funktioniert:

=WENNFEHLER(INDEX('G:\Ordner1\Ordner2\Ordner3\Ordner4\[Tabelle]Arbeitsblatt'!$B$3:$B$63023;VERGLEICH(A7;('G:\Ordner1\Ordner2\Ordner3\Ordner4\[Tabelle]Arbeitsblatt'!$B$3:$B$63023;0;);1);"")

Diese Formel zeigt nach dem Aktualisieren einen #WERT!-Fehler:

=WENN($A7="";"";WENN(ZÄHLENWENN('G:\Ordner1\Ordner2\Ordner3\Ordner4\[Tabelle]Arbeitsblatt'!$B$3:$B$63023;$A7)=0;"nicht vorhanden";WENN(ZÄHLENWENNS('G: ..... und so weiter


Hat jemande eine Idee, was hier das Problem sein könnte?

Viele Grüße
Max
Antwortento top
#2
(21.08.2019, 08:37)max0 schrieb: Diese Formel zeigt nach dem Aktualisieren einen #WERT!-Fehler:

=WENN($A7="";"";WENN(ZÄHLENWENN('G:\Ordner1\Ordner2\Ordner3\Ordner4\[Tabelle]Arbeitsblatt'!$B$3:$B$63023;$A7)=0;"nicht vorhanden";WENN(ZÄHLENWENNS('G: ..... und so weiter
Schon seit 1857 kann ZÄHELNWENN() nicht auf geschlossene Dateien zugreifen.
Grüsse
Detlef

Bitte keine PN!
Seit Nikolaus 2012 mit Excel 2010. Seit Ostern 2015 mit Office 365
Antwortento top
#3
Hallo Detlef, 

vielen Dank für Deine Antwort!

Wenn das schon seit 1857 so ist, sollte man das natürlich wissen...

Für Interessierte: 

Dank Detlefs Antwort habe ich den Fehler gelöst, indem ich die Formel in die ursprüngliche Testfallmatrix gelegt habe. Die Übersichts-Arbeitsmappe hat nun einfach einen Link zur ursprünglichen Testfallmatrix.

Hätte man alleine drauf kommen können, aber manchmal sieht man eben den Wald vor lauter Bäumen nicht. 16

Wie immer, vielen Dank für die schnelle Hilfe!

Gruß
Max
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste