Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Vergleichen von Wert aus Zelle mit werten in Tabelle und Ausgabe von anderem wert
#1
    Hallo Leute, ich bin neu hier.

Ich bin hier zuhause am verzweifeln weil ich bei Google und Youtube nix finde wie ich mein Problem lösen kann, vielleicht könnt ihr mir ja helfenSmile

Folgendes soll erfüllt werden:

ZelleA1 hat einen Dropdown menü in dem es Mögliochkeit A und B gibt.
ZelleA2 hat einen Frei eintragbaren Zahlenwert z.b. 190
ZelleB1 soll einen Wert bekommen, der Festgesetzt in einer Tabelle auf einem Anderen Sheet steht
Die Zahl aus Zelle A2 soll mit den Zahlen in der Tabelle verglichen werden
In der Tabelle stehen 5 Zahlen und dazu 5 werte
Wenn die Zahl in ZelleA2 < Zahl1 ist soll wert1 in ZelleB1 stehen usw.
Wenn die Zahl in ZelleA2 >Zahl5 ist soll wert5 in ZelleB1 stehen
Dazu ist die Zahl1-5 unterschiedlich je nach Möglichkeit A oder B aber die Werte1-5 die ausgegeben werden sollen, nicht.

Ich habs jetzt schon mit WENN, SVERWEIS, INDEX UND VERGLEICH, versucht aber nix funktioniert..

Also im Grunde genommen, auch wenn ich mich doppelt ausdrücke, soll in B1 eine Formel die Wenn in A1 Male steht den Wert aus A2 mit der Tabelle für Male vergleichen, das vergleichen soll bis wert 5 mit kleiner als und bei wert 5 größer als passieren, und dann den dazugehörigen multiplikator (ausgabewert) in zelle B1 einfügen. Zusätzliche soll das gleiche für Female passieren.


Um es Bildlich darzustellen

A          B          Ausgabewert
120      139            -1
130      142            0
140      175            1
150      191            2


Ich füge auch nochmal ein Screen an

MfG
Antwortento top
#2
Hallöchen,

Du könntest es so lösen

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
1MalleFeemalleMalle
200-1110
3120139-1-1
41301420
51401751
61501912
799999999992

ZelleFormel
E3=WENN(E1="Malle";SVERWEIS(E2;A2:C7;3;WAHR);SVERWEIS(E2;B2:C7;2;WAHR))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • Streel
Antwortento top
#3
Danke für die Schnelle Antwort, habe deinen Lösungsansatz direkt mal ausprobiert und leider funktioniert er bei mir nicht, in der Zelle steht nun #NV
Antwortento top
#4
Hallo,

Die Formel von schauan stimmt.

Evtl. vergleichst du Text mit Zahlen (mit =istzahl( ) überprüfen) oder der Wert ist tatsächlich nicht vorhanden.

Ansonsten mal eine Beispielmappe hochladen.
Cadmus
Antwortento top
#5
Hallöchen,

und natürlich nicht meine verhunzten Geschlechter verwenden Smile
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#6
Ne Funktioniert nicht, jedenfalls nicht ganz so wie ich es möchte. NV ist jetzt weg, hatte die falsche Zelle für die prüfung drin :D

trotzdem vergleicht er jetzt den wert nicht richtig. ich möchte ja das er guckt ob die eingegebene Höhe in cm auf die in der tabelle hinterlegten größen passt, aber nicht wahr oder flasch sondern größer und kleiner als.

Heißt. in Zelle a2 steht 140 in der tabelle ist größe bis 170 eingetragen und bis 170 soll der wert 2 ausgegeben werden. 

wenn ich jetzt bei female nehme und 140 eintrage macht er #nv weil er ja die direkten zahlen vergleicht und nicht alle zahlen bis 170 sind 2 etc und bei dem letzten wert soll es dann alles über 195 sein.

Muss ich dafür die Tabelle umschreiben? oder geht es mit ner formel?
Antwortento top
#7
Hallöchen,

durch das WAHR wird doch genau das erreicht ...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#8
Ne, offensichtlich, nimmt das WAHR nur +-10. 
Es kann ja aber auch sein das eine Person 140 oder 120 groß ist. Muss ich also noch mehr Werte in die Tabelle eintragen weil Excel das was ich will, nicht kann ?
Antwortento top
#9
irgendwas machst DU anders als ich ...

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJKLMNOPQRSTU
1MalleFeemalleMalleMalleMalleMalleMalleMalleMalleMalleMalleMalleMalleMalleMalleMalleMalleMalleMalle
2001255075100125150175200225250275300325350375400425
3100139211122223333444455
42001423
53001754
64001915
799999999996

ZelleFormel
E3=WENN(E1="Malle";SVERWEIS(E2;$A$2:$C$7;3;WAHR);SVERWEIS(E2;$B$2:$C$7;2;WAHR))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#10
Vielleicht liegt es daran das meine Tabelle keine 0 beinhaltet, ich füge mal 0 mit dem gleichen wert von 170 dazu und gucke ob er es dann checkt.
Ich habe ja den Screen von meiner Tabelle oben, das ist die original tabelle.

Habs jetzt mal mit 0 oben und 999 unten begrenzt und jetzt funzt es, ja. Danke für die hilfeSmile
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste