Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

VBA Problem
#1
Guten Morgen, 
vorab, ich habe wenig bis sehr wenig von VBA.

Mein Problem ist folgendes. Dieses Makro funktioniert (unter personal.xlmb gespeichert)  einwandfrei für alle geöffneten Dateien .


Option Explicit
Public Sub Verknüpfung_senden()
    Dim strHTMLLink As String
    Dim objOutApp As Object
    Dim strFile As String
    Dim strTMP As String
    On Error GoTo Fin
    'strFile = ThisWorkbook.Path & "\" & ThisWorkbook.Name
    strFile = ActiveWorkbook.Path & "\" & ActiveWorkbook.Name
    Set objOutApp = CreateObject("Outlook.Application").CreateItem(0)
    strHTMLLink = "

" & _
        Right$(strFile, Len(strFile) - InStrRev(strFile, "\")) & "

"
    With objOutApp
        ' Standardsignatur aufrufen und...
        .GetInSpector.Display
        ' ... zwischenspeichern
        strTMP = .htmlBody
        ' An...
        .To = ""
        '.CC = "An@WenNoch.de
        ' Versteckte Empfänger...
        '.BCC = "AuchNoch@AnDen.de; UndNoch@AnJene.de"
        ' Anhang...
        '.Attachments.Add "C:\Temp\IrgendwasVonIrgendwo.xlsx"
        ' Betreff...
        .Subject = ActiveWorkbook.Name
        '.Subject = ActiveWorkbook.Path & "\" & ActiveWorkbook.Name
        ' Body...
        .htmlBody = "Sehr geehrte Damen und Herren,

" & _
                "anbei erhalten Sie den Link zu der Datei:

" & _
                  strHTMLLink & "

" & _
                .htmlBody & ""
           
        ' Hier wird die Mail angezeigt, sonst gleich ".Send"
        .Display
        '.Send
    End With
Fin:
    Set objOutApp = Nothing
    If Err.Number <> 0 Then MsgBox "Fehler: " & _
        Err.Number & " " & Err.Description
End Sub






Nun habe ich es direkt in einer Datei gespeichert. Zuerst funktionierte es hier auch, jedoch wurde dann etwas an der Datei (nicht im Makro) geändert.
Das Makro wirft folgende Fehlermeldung "Fehler beim kompilieren. Projekt oder Bibliothek nicht gefunden" und markiert das "Right$".

Wer kann mir bitte helfen?

LG
Justin

Antwortento top
#2
Gelöscht, wegen fehlerhaftem Tipp.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Hallo,
ich glaube nicht, dass es mit dem Dollarzeichen zu tun.
Schau mal in den Verweisen ob da eins mit Fehlend gezeigt wird.
Im VBA Bereich im Menü unter Exras Verweise.
Gruß Atilla
Antwortento top
#4
Hallo, 19

das Dollarzeichen bitte nicht rausnehmen! 21

Es ist auf unseren heutigen Maschinen und bei einmaligem Einsatz eigentlich unerheblich, ob mit oder ohne "$". Besser ist es aber mit... Confused

Left, Left$ - Mid, Mid$ - Right, Right$ - Doppelte Lottchen?
________
Servus
Case
Antwortento top
#5
Hi, 

ja da steht :

nicht vorhanden: MS Office 16.0Objekt Library

Und nun?

Ich wünsche schon mal ein schönes Wochenende, ich werde mich Montag wieder melden!

Danke

LG
Justin
Antwortento top
#6
Hallo,

das Häkchen raus nehmen, mit OK das Fenster schließen, Datei speichern und schließen und wieder öffnen.
Das sollte Dein Problem gelöst haben.
Gruß Atilla
[-] Folgende(r) 1 Benutzer sagt Danke an atilla für diesen Beitrag:
  • Justin
Antwortento top
#7
Super!!!!!!!


hat funktioniert, danke sehr!!

LG
Justin
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste