Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

VBA - Excel erkennt Formel nicht
#1
Hallo zusammen,

wie ihr erkennen könnt, soll hier schlicht ein Ja/Nein eingelesen werden und im Falle von "Ja" ein Sverweis eingefügt werden, der sich auf eine hinterlegte Masterdatei bezieht. 

Die Formel wird hinterlegt, funktioniert aber nicht. Erst wenn ich die Zeile mit Enter bestätige erkennt Excel sie.
Weiß jemand woran das liegt?

Anbei meine Eingabe in VBA:

Sub Plantbezug()
    Dim Eingabewert As String
    Eingabewert = MsgBox("Möchten Sie die zugehörige Plant anzeigen?", vbYesNo)
    If Eingabewert = vbYes Then
        Range("P2") = "=SVERWEIS(A2, [MASTER.xls]Sheet1!$A$2:$I$881,8,0)"
    End If
End Sub
Antwortento top
#2
Hallo,

die Standardeigenschaft von Range ist Value. Um eine Formel per VBA einzugeben, musst Du Formula für eine
englische Formel oder FormulaLocal für eine lokalisierte Formel - also hier Deutsch - verwenden.

Wenn FormulaLocal, dann auch mit deutscher Formel, also in der Regel mit ; als Trennzeichen...

Code:
Range("P2").FormulaLocal = "=SVERWEIS(A2;[MASTER.xls]Sheet1!$A$2:$I$881;8;0)"

Besser ist eine englische Variante ...

Code:
Range("P2").Formula = "=VLOOKUP(A2,[MASTER.xls]Sheet1!$A$2:$I$881,8,0)"

Gruß
Microsoft Excel Expert · Microsoft Most Valuable Professional (MVP) from 01/2011 - 06/2019
https://de.excel-translator.de :: Online Excel-Formel-Übersetzer :: Alle Übersetzungen der Excel Funktionen & Fehlerwerte
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste