Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Überschneidungen bei Zeiträumen
#1
Hallo,

ich möchte ein Sheet erstellen, dass mir automatisch Überschneidungen bei Urlaubszeiträumen angibt. Über ein anderes Forum konnte ich bereits eine Formel finden um Überschneidungen im Datum zu definieren. Jetzt habe ich aber ein weiteres Parameter: 

   

Nehmen wir an GR möchte seine Vertretung eintragen und wählt hierfür CA aus. CA hat für den angebenen Zeitraum selber bereits einen Vertreter angegeben, da er sich im Urlaub befindet. Jetzt kann CA natürlich nicht GR als Vertreter zur Verfügung stehen und GR muss sich nach einem alternativen Vertreter umsehen.

Meine aktuelle Formel sieht wie folgt aus: 

=WENN(SUMMENPRODUKT(($D$5:$D$20<=E5)*($E$5:$E$20>=D5))>1;"Überschneidung";"okay")

Meine Frage ins Forum ist nun: Wie kann ich das oben beschriebene Parameter (Mitarbeiter/Vertreter) in diese Formel mit einfließen lassen?

Ich hoffe, dass ich mich einigermaßen klar ausgedrückt habe. Sonst bitte fragen.
Antwortento top
#2
Moin!
Mache es nach Altväter-Sitte mit einem Gantt-Diagramm (mit bedingter Formatierung).
Google-Suche
Schließlich haben Millionen ausgehängte Urlaubsplaner durchaus ihren Sinn.

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#3
1. Hast Du 365 Insider? Bitte genaue Modalität bei der Version dazu schreiben; es kommt sehr drauf an.
2. Soll die Überschneidungsangabe auch zum Vertreter als Hauptperson (dann 2mal), oder nur zum Vertreter als Vertreter (dann 1mal)?
3. Kann man häufiger als je 1mal in beiden Spalten vorkommen?
Antwortento top
#4
Hallöchen,

hier mal ein Ansatz für eine zusätzliche Spalte.

Arbeitsblatt mit dem Namen 'Tabelle1'
BCDEF
5AB15B
6BC47
7CD89

ZelleFormel
F5=WENN(SUMMENPRODUKT(($D$5:$D$20<=E5)*($E$5:$E$20>=D5)*($B$5:$B$20=C5))>=1;C5;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste