Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Übereinstimmung mit Bedingung finden
#1
Hallo

ich bin neu hier und brauche Hilfe. Wahrscheinlich ist es ganz einfach, ich komme einfach nicht drauf.
In Spalte A stehen 3stellige Zahlen, in Splate B irgendein Text, in Spalte E wieder eine 3stellige Zahl, welche auch in Spalte A steht. Dort kommt sie aber mehrfach vor. In Spalte D soll einfach ein X gesetzt werden, wenn die Zahl aus Spalte E in Spalte A gefunden wird UND der Text in Spalte B NICHT leer ist. In Spalte E stehen 184 Werte, in Spalte A und B 672.

Vielleicht hat jemand Zeit. Danke!


Angehängte Dateien
.xls   Beispiel_Dirk_.xls (Größe: 38 KB / Downloads: 3)
Antworten Top
#2
Hi,

ohne Deine Datei anzusehen:

ZÄHLENWENNS

https://support.microsoft.com/de-de/offi...8c2a866842
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Nutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Dirk_
Antworten Top
#3
Hallo,

via VBA so:
Code:
Sub mitX()
    Dim arr(), i&, j&, k&
    With Tabelle1
        arr = .Range("E1:E" & .Cells(Rows.Count, 5).End(xlUp).Row)
        For i = 1 To UBound(arr)
            For j = 1 To .Cells(Rows.Count, 1).End(xlUp).Row
                If arr(i, 1) = .Cells(j, 1) Then
                    k = k + 1
                    If k > 1 Then .Cells(j, 4) = "X"
                End If
            Next j
            k = 0
        Next i
    End With
End Sub

Gruß Uwe
[-] Folgende(r) 1 Nutzer sagt Danke an Egon12 für diesen Beitrag:
  • Dirk_
Antworten Top
#4
Hi,

Code:
=WENN(ISTZAHL(VERGLEICH(A1:A672;E:E;0))*(B1:B672<>"");"x";"")
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Nutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Dirk_
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste